Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / alsa / alsa-utils_1.0.15.bb
1 DESCRIPTION = "ALSA Utilities"
2 HOMEPAGE = "http://www.alsa-project.org"
3 SECTION = "console/utils"
4 LICENSE = "GPL"
5 DEPENDS = "alsa-lib ncurses"
6 PR = "r1"
7
8 SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \
9            file://alsa-utils-automake.patch;patch=1 \
10           "
11
12 inherit autotools
13
14 # This are all packages that we need to make. Also, the now empty alsa-utils
15 # ipk depend on them.
16
17 PACKAGES += "\
18              alsa-utils-alsamixer \
19              alsa-utils-midi \
20              alsa-utils-aplay \
21              alsa-utils-amixer \
22              alsa-utils-aconnect \
23              alsa-utils-iecset \
24              alsa-utils-speakertest \
25              alsa-utils-aseqnet \
26              alsa-utils-aseqdump \
27              alsa-utils-alsaconf \
28              alsa-utils-alsactl "
29
30 # We omit alsaconf, because
31 # a) this is a bash script
32 # b) it creates config files not suitable for OE-based distros
33
34 FILES_${PN} = ""
35 FILES_alsa-utils-aplay       = "${bindir}/aplay ${bindir}/arecord"
36 FILES_alsa-utils-amixer      = "${bindir}/amixer"
37 FILES_alsa-utils-alsamixer   = "${bindir}/alsamixer"
38 FILES_alsa-utils-speakertest = "${bindir}/speaker-test ${datadir}/sounds/alsa/ ${datadir}/alsa/"
39 FILES_alsa-utils-midi        = "${bindir}/aplaymidi ${bindir}/arecordmidi ${bindir}/amidi"
40 FILES_alsa-utils-aconnect    = "${bindir}/aconnect"
41 FILES_alsa-utils-aseqnet     = "${bindir}/aseqnet"
42 FILES_alsa-utils-iecset      = "${bindir}/iecset"
43 FILES_alsa-utils-alsactl     = "${sbindir}/alsactl"
44 FILES_alsa-utils-aseqdump    = "${bindir}/aseqdump"
45 FILES_alsa-utils-alsaconf    = "${sbindir}/alsaconf"
46
47 DESCRIPTION_alsa-utils-aplay        = "play (and record) sound files via ALSA"
48 DESCRIPTION_alsa-utils-amixer       = "command-line based control for ALSA mixer and settings"
49 DESCRIPTION_alsa-utils-alsamixer    = "ncurses based control for ALSA mixer and settings"
50 DESCRIPTION_alsa-utils-speakertest  = "ALSA surround speaker test utility"
51 DESCRIPTION_alsa-utils-midi         = "miscalleanous MIDI utilities for ALSA"
52 DESCRIPTION_alsa-utils-aconnect     = "ALSA sequencer connection manager"
53 DESCRIPTION_alsa-utils-aseqnet      = "network client/server on ALSA sequencer"
54 DESCRIPTION_alsa-utils-alsactl      = "saves/restores ALSA-settings in /etc/asound.state"
55 DESCRIPTION_alsa-utils-alsaconf     = "a bash script that creates ALSA configuration files"
56
57 ALLOW_EMPTY_alsa-utils = "1"