Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / adobe-flash / flash-plugin_10.0.12.36.bb
1 # Adobe provides two versions of flash player packages
2 #
3 # One "unversioned" download at :
4 #
5 #     ${ADOBE_MIRROR}/install_flash_player_9_linux.tar.gz
6 #
7 # And the other, versioned, which is encapsulated in RPM.
8 #
9 # We use the versioned one to make sure we can keep track of the
10 # version and thus do repeatable builds at the cost of future download
11 # failures when adobe updates.
12 DESCRIPTION = "Adobe Flash 9 plugin for Mozilla/Firefox web browsers"
13 LICENSE = "AdobeFlash"
14 DEPENDS = "rpm2cpio-native"
15 PR = "r1"
16
17 SRC_URI = "${ADOBE_MIRROR}/flash-plugin-${PV}-release.i386.rpm"
18
19 do_configure() {
20         rpm=${WORKDIR}/flash-plugin-${PV}-release.i386.rpm
21         if [ -f "$rpm" ]; then
22                 rpm2cpio.pl $rpm | cpio -id
23                 find . -type f -exec mv -i {} "`pwd`" \;
24         fi
25 }
26 do_install() {
27         mkdir -p ${D}${libdir}/mozilla/plugins/
28         install -m 0755 libflashplayer.so ${D}${libdir}/mozilla/plugins/
29         # AFAIK this is not needed
30         # install -m 0644 flashplayer.xpt ${D}${libdir}/mozilla/plugins/
31 }
32
33 FILES_${PN} = "${libdir}/* ${libdir}/X11/*"
34
35 COMPATIBLE_HOST = "i.86.*-linux"