Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / aalib / aalib_1.4rc5.bb
1 DEPENDS = "ncurses"
2 DESCRIPTION = "An ASCII art gfx library."
3 SECTION = "libs"
4 LICENSE="LGPL"
5 FILE_PR = "r1"
6
7 SRC_URI = "${SOURCEFORGE_MIRROR}/aa-project/aalib-${PV}.tar.gz \
8            file://configure.patch;patch=1"
9 S = "${WORKDIR}/aalib-1.4.0"
10
11 inherit autotools
12
13 EXTRA_OECONF = '--without-x11-driver --without-slang-driver \
14                 --with-curses-driver --without-gpm \
15                 --without-x --with-ncurses=${STAGING_LIBDIR}/..'
16
17 do_stage() {
18     oe_libinstall -a -so -C src libaa ${STAGING_LIBDIR}
19         install -d ${STAGING_INCDIR}/
20         install -m 0644 src/*.h ${STAGING_INCDIR}/
21 }