xfce: remove pkgconfig hacks and switch to autotools.bbclass, tweak packaging
[vuplus_openembedded] / classes / xfce.bbclass
1 # xfce.oeclass
2 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 # Global class to make it easier to maintain XFCE packages
6
7 HOMEPAGE = "http://www.xfce.org"
8 LICENSE = "LGPL-2"
9 DEPENDS += "startup-notification"
10
11 SRC_URI = "http://www.us.xfce.org/archive/xfce-${PV}/src/${PN}-${PV}.tar.bz2"
12
13 inherit autotools
14
15 AUTOTOOLS_STAGE_PKGCONFIG = "1"
16
17 EXTRA_OECONF += "--with-pluginsdir=${libdir}/xfce4/panel-plugins/"
18
19 # FIXME:  Put icons in their own package too?
20
21 FILES_${PN} += "${datadir}/icons/* ${datadir}/applications/* ${libdir}/xfce4/modules/*.so*"
22 FILES_${PN}-doc += "${datadir}/xfce4/doc"
23
24 FILES_${PN}-dev += "${libdir}/xfce4/*/*.la"
25 FILES_${PN}-dbg += "${libdir}/xfce4/*/.debug"
26