merge of '16141cfb7ddd939f1759a94546b737b35c0ece43'
[vuplus_openembedded] / classes / xfce.bbclass
1 # xfce.oeclass
2 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 # Global class to make it easier to maintain XFCE packages
6
7 HOMEPAGE = "http://www.xfce.org"
8 LICENSE = "LGPL-2"
9
10 def xfce_extension(ver):
11         ext = "gz"
12         if ver == "4.3.99.2":
13                 ext = "bz2"
14         return ext
15
16 SRC_URI = "http://www.us.xfce.org/archive/xfce-${PV}/src/${PN}-${PV}.tar.${@xfce_extension("${PV}")}"
17
18 inherit autotools
19
20 EXTRA_OECONF += "--with-pluginsdir=${libdir}/xfce4/panel-plugins/"
21
22 # FIXME:  Put icons in their own package too?
23
24 FILES_${PN} += "${datadir}/icons/* ${datadir}/applications/* ${libdir}/xfce4/modules/*.so*"
25 FILES_${PN}-doc += "${datadir}/xfce4/doc"