Merge bk://oe-devel.bkbits.net/openembedded
[vuplus_openembedded] / classes / xfce.bbclass
1 # xfce.oeclass
2 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 # Global class to make it easier to maintain XFCE packages
6
7 HOMEPAGE="http://www.xfce.org"
8 LICENSE="LGPL-2"
9
10 SRC_URI="http://www.us.xfce.org/archive/xfce-${PV}/src/${PN}-${PV}.tar.gz"
11
12 # Most, but not *all* packages use pkgconfig, so we can't include it here
13 # too
14
15 inherit autotools
16
17 EXTRA_OECONF += "--with-pluginsdir=${libdir}/xfce4/panel-plugins/"
18
19 # FIXME:  Put icons in their own package too?
20
21 PACKAGES += "${PN}-mcs-plugins ${PN}-panel-plugins"
22
23 FILES_${PN} += "${datadir}/icons/* ${datadir}/applications/* ${libdir}/xfce4/modules/*.so*"
24 FILES_${PN}-panel-plugins += "${libdir}/xfce4/panel-plugins/*.so*"
25 FILES_${PN}-doc += " ${datadir}/xfce4/doc"
26 FILES_${PN}-mcs-plugins="${libdir}/xfce4/mcs-plugins/*.so"