import clean BK tree at cset 1.3670
[vuplus_openembedded] / classes / update-alternatives.bbclass
1 # defaults
2 ALTERNATIVE_PRIORITY = "10"
3 ALTERNATIVE_LINK = "${bindir}/${ALTERNATIVE_NAME}"
4
5 update_alternatives_postinst() {
6 update-alternatives --install ${ALTERNATIVE_LINK} ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH} ${ALTERNATIVE_PRIORITY}
7 }
8
9 update_alternatives_postrm() {
10 update-alternatives --remove ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH}
11 }
12
13 python __anonymous() {
14         if bb.data.getVar('ALTERNATIVE_NAME', d) == None:
15                 raise bb.build.FuncFailed, "%s inherits update-alternatives but doesn't set ALTERNATIVE_NAME" % bb.data.getVar('FILE', d)
16         if bb.data.getVar('ALTERNATIVE_PATH', d) == None:
17                 raise bb.build.FuncFailed, "%s inherits update-alternatives but doesn't set ALTERNATIVE_PATH" % bb.data.getVar('FILE', d)
18 }
19
20 python populate_packages_prepend () {
21         pkg = bb.data.getVar('PN', d, 1)
22         bb.note('adding update-alternatives calls to postinst/postrm for %s' % pkg)
23         postinst = bb.data.getVar('pkg_postinst_%s' % pkg, d, 1) or bb.data.getVar('pkg_postinst', d, 1)
24         if not postinst:
25                 postinst = '#!/bin/sh\n'
26         postinst += bb.data.getVar('update_alternatives_postinst', d, 1)
27         bb.data.setVar('pkg_postinst_%s' % pkg, postinst, d)
28         postrm = bb.data.getVar('pkg_postrm_%s' % pkg, d, 1) or bb.data.getVar('pkg_postrm', d, 1)
29         if not postrm:
30                 postrm = '#!/bin/sh\n'
31         postrm += bb.data.getVar('update_alternatives_postrm', d, 1)
32         bb.data.setVar('pkg_postrm_%s' % pkg, postrm, d)
33 }