Add sourcepkg.bbclass, a crude way to tar up the patched sources into DL_DIR/sourcepk...
[vuplus_openembedded] / classes / sourcepkg.bbclass
1
2 do_tarballing(){
3
4         mkdir -p ${DL_DIR}/sourcepkg/
5         cd ${WORKDIR}
6         echo '.pc' > tar-exclude
7         tar cjvf ${DL_DIR}/sourcepkg/${P}.tar.bz2  `basename ${S}` -X tar-exclude
8         md5sum ${DL_DIR}/sourcepkg/${P}.tar.bz2 > ${DL_DIR}/sourcepkg/${P}.tar.bz2.md5
9 }
10
11 addtask tarballing after do_patch before do_configure
12
13