merge of '629d7abe4cdeb66f4256659308d040ed78152a2a'
[vuplus_openembedded] / classes / siteinfo.bbclass
1 # This class exists to provide information about the targets that
2 # may be needed by other classes and/or recipes. If you add a new
3 # target this will probably need to be updated.
4
5 #
6 # Returns information about 'what' for the named target 'target'
7 # where 'target' == "<arch>-<os>"
8 #
9 # 'what' can be one of
10 # * target: Returns the target name ("<arch>-<os>")
11 # * endianess: Return "be" for big endian targets, "le" for little endian
12 # * bits: Returns the bit size of the target, either "32" or "64"
13 # * libc: Returns the name of the c library used by the target
14 #
15 # It is an error for the target not to exist.
16 # If 'what' doesn't exist then an empty value is returned
17 #
18 def get_siteinfo_list(d):
19        import bb
20
21        target = bb.data.getVar('HOST_ARCH', d, 1) + "-" + bb.data.getVar('HOST_OS', d, 1)
22
23        targetinfo = {\
24                "armeb-linux":             "endian-big bit-32 common-glibc arm-common",\
25                "armeb-linux-uclibc":      "endian-big bit-32 common-uclibc arm-common",\
26                "arm-linux":               "endian-little bit-32 common-glibc arm-common",\
27                "arm-linux-gnueabi":       "endian-little bit-32 common-glibc arm-common arm-linux",\
28                "arm-linux-uclibc":        "endian-little bit-32 common-uclibc arm-common",\
29                "arm-linux-uclibcgnueabi": "endian-little bit-32 common-uclibc arm-common arm-linux-uclibc",\
30                "i386-linux":              "endian-little bit-32 common-glibc ix86-common",\
31                "i486-linux":              "endian-little bit-32 common-glibc ix86-common",\
32                "i586-linux":              "endian-little bit-32 common-glibc ix86-common",\
33                "i686-linux":              "endian-little bit-32 common-glibc ix86-common",\
34                "i386-linux-uclibc":       "endian-little bit-32 common-uclibc ix86-common",\
35                "i486-linux-uclibc":       "endian-little bit-32 common-uclibc ix86-common",\
36                "i586-linux-uclibc":       "endian-little bit-32 common-uclibc ix86-common",\
37                "i686-linux-uclibc":       "endian-little bit-32 common-uclibc ix86-common",\
38                "mipsel-linux":            "endian-little bit-32 common-glibc",\
39                "mipsel-linux-uclibc":     "endian-little bit-32 common-uclibc",\
40                "powerpc-darwin":          "endian-big bit-32 common-darwin",\
41                "powerpc-linux":           "endian-big bit-32 common-glibc",\
42                "powerpc-linux-uclibc":    "endian-big bit-32 common-uclibc",\
43                "sh3-linux":               "endian-little bit-32 common-glibc sh-common",\
44                "sh4-linux":               "endian-little bit-32 common-glibc sh-common",\
45                "sh4-linux-uclibc":        "endian-little bit-32 common-uclibc sh-common",\
46                "sparc-linux":             "endian-big bit-32 common-glibc",\
47                "x86_64-linux":            "endian-little bit-64 common-glibc",\
48                "x86_64-linux-uclibc":     "endian-little bit-64 common-uclibc"}
49        if target in targetinfo:
50                info = targetinfo[target].split()
51                info.append(target)
52                info.append("common")
53                return info
54        else:
55                bb.error("Information not available for target '%s'" % target)
56
57
58 #
59 # Define which site files to use. We check for several site files and
60 # use each one that is found, based on the list returned by get_siteinfo_list()
61 #
62 # Search for the files in the following directories:
63 # 1) ${BBPATH}/site (in reverse) - app specific, then site wide
64 # 2) ${FILE_DIRNAME}/site-${PV}         - app version specific
65 #
66 def siteinfo_get_files(d):
67        import bb, os
68
69        sitefiles = ""
70
71        # Determine which site files to look for
72        sites = get_siteinfo_list(d)
73        sites.append("common");
74
75        # Check along bbpath for site files and append in reverse order so
76        # the application specific sites files are last and system site
77        # files first.
78        path_bb = bb.data.getVar('BBPATH', d, 1)
79        for p in (path_bb or "").split(':'):
80                tmp = ""
81                for i in sites:
82                        fname = os.path.join(p, 'site', i)
83                        if os.path.exists(fname):
84                                tmp += fname + " "
85                sitefiles = tmp + sitefiles;
86
87        # Now check for the applications version specific site files
88        path_pkgv = os.path.join(bb.data.getVar('FILE_DIRNAME', d, 1), "site-" + bb.data.getVar('PV', d, 1))
89        for i in sites:
90                fname = os.path.join(path_pkgv, i)
91                if os.path.exists(fname):
92                        sitefiles += fname + " "
93
94        bb.debug(1, "SITE files " + sitefiles);
95        return sitefiles
96
97 #
98 # Export CONFIG_SITE to the enviroment. The autotools will make use
99 # of this to determine where to load in variables from. This is a
100 # space seperate list of shell scripts processed in the order listed.
101 #
102 export CONFIG_SITE = "${@siteinfo_get_files(d)}"
103
104
105 def siteinfo_get_endianess(d):
106        info = get_siteinfo_list(d)
107        if 'endian-little' in info:
108               return "le"
109        elif 'endian-big' in info:
110               return "be"
111        bb.error("Site info could not determine endianess for target")
112
113 def siteinfo_get_bits(d):
114        info = get_siteinfo_list(d)
115        if 'bit-32' in info:
116               return "32"
117        elif 'bit-64' in info:
118               return "64"
119        bb.error("Site info could not determine bit size for target")
120
121 #
122 # Make some information available via variables
123 #
124 SITEINFO_ENDIANESS  = "${@siteinfo_get_endianess(d)}"
125 SITEINFO_BITS       = "${@siteinfo_get_bits(d)}"
126
127