merge of '0b604857bbf871639fdb43ee8380222e8ef64bb7'
[vuplus_openembedded] / classes / siteinfo.bbclass
1 # This class exists to provide information about the targets that
2 # may be needed by other classes and/or recipes. If you add a new
3 # target this will probably need to be updated.
4
5 #
6 # Returns information about 'what' for the named target 'target'
7 # where 'target' == "<arch>-<os>"
8 #
9 # 'what' can be one of
10 # * target: Returns the target name ("<arch>-<os>")
11 # * endianess: Return "be" for big endian targets, "le" for little endian
12 # * bits: Returns the bit size of the target, either "32" or "64"
13 # * libc: Returns the name of the c library used by the target
14 #
15 # It is an error for the target not to exist.
16 # If 'what' doesn't exist then an empty value is returned
17 #
18 def get_siteinfo_list(d):
19        import bb
20
21        target = bb.data.getVar('HOST_ARCH', d, 1) + "-" + bb.data.getVar('HOST_OS', d, 1)
22
23        targetinfo = {\
24                "armeb-linux":             "endian-big bit-32 common-linux common-glibc arm-common",\
25                "armeb-linux-gnueabi":     "endian-big bit-32 common-linux common-glibc arm-common armeb-linux",\
26                "armeb-linux-uclibc":      "endian-big bit-32 common-linux common-uclibc arm-common",\
27                "armeb-linux-uclibcgnueabi": "endian-big bit-32 common-linux common-uclibc arm-common armeb-linux-uclibc",\
28                "arm-darwin":              "endian-little bit-32 common-darwin",\
29                "arm-linux":               "endian-little bit-32 common-linux common-glibc arm-common",\
30                "arm-linux-gnueabi":       "endian-little bit-32 common-linux common-glibc arm-common arm-linux",\
31                "arm-linux-uclibc":        "endian-little bit-32 common-linux common-uclibc arm-common",\
32                "arm-linux-uclibcgnueabi": "endian-little bit-32 common-linux common-uclibc arm-common arm-linux-uclibc",\
33                "avr32-linux-uclibc":      "endian-big bit-32 common-linux common-uclibc avr32-common",\
34                "bfin-uclinux-uclibc":       "endian-little bit-32 common-uclibc bfin-common",\
35                "i386-linux":              "endian-little bit-32 common-linux common-glibc ix86-common",\
36                "i486-linux":              "endian-little bit-32 common-linux common-glibc ix86-common",\
37                "i586-linux":              "endian-little bit-32 common-linux common-glibc ix86-common",\
38                "i686-linux":              "endian-little bit-32 common-linux common-glibc ix86-common",\
39                "i386-linux-uclibc":       "endian-little bit-32 common-linux common-uclibc ix86-common",\
40                "i486-linux-uclibc":       "endian-little bit-32 common-linux common-uclibc ix86-common",\
41                "i586-linux-uclibc":       "endian-little bit-32 common-linux common-uclibc ix86-common",\
42                "i686-linux-uclibc":       "endian-little bit-32 common-linux common-uclibc ix86-common",\
43                "mipsel-linux":            "endian-little bit-32 common-linux common-glibc",\
44                "mipsel-linux-uclibc":     "endian-little bit-32 common-linux common-uclibc",\
45                "mips-linux":              "endian-big bit-32 common-linux common-glibc",\
46                "mips-linux-uclibc":       "endian-big bit-32 common-linux common-uclibc",\
47                "powerpc-darwin":          "endian-big bit-32 common-darwin",\
48                "ppc-linux":               "endian-big bit-32 common-linux common-glibc powerpc-common",\ 
49                "powerpc-linux":           "endian-big bit-32 common-linux common-glibc powerpc-common",\
50                "powerpc-linux-uclibc":    "endian-big bit-32 common-linux common-uclibc powerpc-common",\
51                "sh3-linux":               "endian-little bit-32 common-linux common-glibc sh-common",\
52                "sh4-linux":               "endian-little bit-32 common-linux common-glibc sh-common",\
53                "sh4-linux-uclibc":        "endian-little bit-32 common-linux common-uclibc sh-common",\
54                "sparc-linux":             "endian-big bit-32 common-linux common-glibc",\
55                "x86_64-linux":            "endian-little bit-64 common-linux common-glibc",\
56                "x86_64-linux-uclibc":     "endian-little bit-64 common-linux common-uclibc"}
57        if target in targetinfo:
58                info = targetinfo[target].split()
59                info.append(target)
60                info.append("common")
61                return info
62        else:
63                bb.error("Information not available for target '%s'" % target)
64
65
66 #
67 # Define which site files to use. We check for several site files and
68 # use each one that is found, based on the list returned by get_siteinfo_list()
69 #
70 # Search for the files in the following directories:
71 # 1) ${BBPATH}/site (in reverse) - app specific, then site wide
72 # 2) ${FILE_DIRNAME}/site-${PV}         - app version specific
73 #
74 def siteinfo_get_files(d):
75        import bb, os
76
77        sitefiles = ""
78
79        # Determine which site files to look for
80        sites = get_siteinfo_list(d)
81        sites.append("common");
82
83        # Check along bbpath for site files and append in reverse order so
84        # the application specific sites files are last and system site
85        # files first.
86        path_bb = bb.data.getVar('BBPATH', d, 1)
87        for p in (path_bb or "").split(':'):
88                tmp = ""
89                for i in sites:
90                        fname = os.path.join(p, 'site', i)
91                        if os.path.exists(fname):
92                                tmp += fname + " "
93                sitefiles = tmp + sitefiles;
94
95        # Now check for the applications version specific site files
96        path_pkgv = os.path.join(bb.data.getVar('FILE_DIRNAME', d, 1), "site-" + bb.data.getVar('PV', d, 1))
97        for i in sites:
98                fname = os.path.join(path_pkgv, i)
99                if os.path.exists(fname):
100                        sitefiles += fname + " "
101
102        bb.debug(1, "SITE files " + sitefiles);
103        return sitefiles
104
105 #
106 # Export CONFIG_SITE to the enviroment. The autotools will make use
107 # of this to determine where to load in variables from. This is a
108 # space seperate list of shell scripts processed in the order listed.
109 #
110 export CONFIG_SITE = "${@siteinfo_get_files(d)}"
111
112
113 def siteinfo_get_endianess(d):
114        info = get_siteinfo_list(d)
115        if 'endian-little' in info:
116               return "le"
117        elif 'endian-big' in info:
118               return "be"
119        bb.error("Site info could not determine endianess for target")
120
121 def siteinfo_get_bits(d):
122        info = get_siteinfo_list(d)
123        if 'bit-32' in info:
124               return "32"
125        elif 'bit-64' in info:
126               return "64"
127        bb.error("Site info could not determine bit size for target")
128
129 #
130 # Make some information available via variables
131 #
132 SITEINFO_ENDIANESS  = "${@siteinfo_get_endianess(d)}"
133 SITEINFO_BITS       = "${@siteinfo_get_bits(d)}"
134
135