merge of 67ad681c17b58ee0ff1e672b4aa634ab523a9e11
[vuplus_openembedded] / classes / sdl.bbclass
1 #
2 # (C) Michael 'Mickey' Lauer <mickey@Vanille.de>
3 #
4
5 DEPENDS += "virtual/libsdl libsdl-mixer libsdl-image"
6
7 APPDESKTOP ?= "${PN}.desktop"
8 APPNAME ?= "${PN}"
9 APPIMAGE ?= "${PN}.png"
10
11 sdl_do_sdl_install() {
12         install -d ${D}${palmtopdir}/bin
13         install -d ${D}${palmtopdir}/pics
14         install -d ${D}${palmtopdir}/apps/Games
15         ln -sf ${bindir}/${APPNAME} ${D}${palmtopdir}/bin/${APPNAME}
16         install -m 0644 ${APPIMAGE} ${D}${palmtopdir}/pics/${PN}.png
17
18         if [ -e "${APPDESKTOP}" ]
19         then
20                 echo ${APPDESKTOP} present, installing to palmtopdir...
21                 install -m 0644 ${APPDESKTOP} ${D}${palmtopdir}/apps/Games/${PN}.desktop
22         else
23                 echo ${APPDESKTOP} not present, creating one on-the-fly...
24                 cat >${D}${palmtopdir}/apps/Games/${PN}.desktop <<EOF
25 [Desktop Entry]
26 Note=Auto Generated... this may be not what you want
27 Comment=${DESCRIPTION}
28 Exec=${APPNAME}
29 Icon=${PN}.png
30 Type=Application
31 Name=${PN}
32 EOF
33         fi
34 }
35
36 EXPORT_FUNCTIONS do_sdl_install
37 addtask sdl_install after do_compile before do_populate_staging
38
39 SECTION = "x11/games"
40 SECTION_${PN}-opie = "opie/games"
41
42 PACKAGES += "${PN}-opie"
43 RDEPENDS_${PN}-opie += "${PN}"
44 FILES_${PN}-opie = "${palmtopdir}"