merge of '5f324e98b61ec50554d929eb59723aaef495ef64'
[vuplus_openembedded] / classes / sanity.bbclass
1 #
2 # Sanity check the users setup for common misconfigurations
3 #
4
5 def raise_sanity_error(msg):
6         import bb
7         bb.fatal(""" Openembedded's config sanity checker detected a potential misconfiguration.
8         Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
9         Following is the list of potential problems / advisories:
10         
11         %s""" % msg)
12
13 def check_conf_exists(fn, data):
14         import bb, os
15
16         bbpath = []
17         fn = bb.data.expand(fn, data)
18         vbbpath = bb.data.getVar("BBPATH", data)
19         if vbbpath:
20                 bbpath += vbbpath.split(":")
21         for p in bbpath:
22                 currname = os.path.join(bb.data.expand(p, data), fn)
23                 if os.access(currname, os.R_OK):
24                         return True
25         return False
26
27 def check_app_exists(app, d):
28         from bb import which, data
29
30         app = data.expand(app, d)
31         path = data.getVar('PATH', d)
32         return len(which(path, app)) != 0
33
34
35 def check_sanity(e):
36         from bb import note, error, data, __version__
37         from bb.event import Handled, NotHandled, getName
38         try:
39                 from distutils.version import LooseVersion
40         except ImportError:
41                 def LooseVersion(v): print "WARNING: sanity.bbclass can't compare versions without python-distutils"; return 1
42         import os
43
44         # Check the bitbake version meets minimum requirements
45         minversion = data.getVar('BB_MIN_VERSION', e.data , True)
46         if not minversion:
47                 # Hack: BB_MIN_VERSION hasn't been parsed yet so return 
48                 # and wait for the next call
49                 print "Foo %s" % minversion
50                 return
51
52         if 0 == os.getuid():
53                 raise_sanity_error("Do not use Bitbake as root.")
54
55         messages = ""
56
57         if (LooseVersion(__version__) < LooseVersion(minversion)):
58                 messages = messages + 'Bitbake version %s is required and version %s was found\n' % (minversion, __version__)
59
60         # Check TARGET_ARCH is set
61         if data.getVar('TARGET_ARCH', e.data, True) == 'INVALID':
62                 messages = messages + 'Please set TARGET_ARCH directly, or choose a MACHINE or DISTRO that does so.\n'
63         
64         # Check TARGET_OS is set
65         if data.getVar('TARGET_OS', e.data, True) == 'INVALID':
66                 messages = messages + 'Please set TARGET_OS directly, or choose a MACHINE or DISTRO that does so.\n'
67
68         assume_provided = data.getVar('ASSUME_PROVIDED', e.data , True).split()
69         # Check user doesn't have ASSUME_PROVIDED = instead of += in local.conf
70         if "diffstat-native" not in assume_provided:
71                 messages = messages + 'Please use ASSUME_PROVIDED +=, not ASSUME_PROVIDED = in your local.conf\n'
72         
73         # Check that the MACHINE is valid
74         if not check_conf_exists("conf/machine/${MACHINE}.conf", e.data):
75                 messages = messages + 'Please set a valid MACHINE in your local.conf\n'
76         
77         # Check that the DISTRO is valid
78         # need to take into account DISTRO renaming DISTRO
79         if not ( check_conf_exists("conf/distro/${DISTRO}.conf", e.data) or check_conf_exists("conf/distro/include/${DISTRO}.inc", e.data) ):
80                 messages = messages + "DISTRO '%s' not found. Please set a valid DISTRO in your local.conf\n" % data.getVar("DISTRO", e.data, True )
81
82         missing = ""
83
84         if not check_app_exists("${MAKE}", e.data):
85                 missing = missing + "GNU make,"
86
87         if not check_app_exists('${BUILD_PREFIX}gcc', e.data):
88                 missing = missing + "C Compiler (${BUILD_PREFIX}gcc),"
89
90         if not check_app_exists('${BUILD_PREFIX}g++', e.data):
91                 missing = missing + "C++ Compiler (${BUILD_PREFIX}g++),"
92
93         required_utilities = "patch help2man diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk md5sum stty"
94
95         for util in required_utilities.split():
96                 if not check_app_exists( util, e.data ):
97                         missing = missing + "%s," % util
98
99         if missing != "":
100                 missing = missing.rstrip(',')
101                 messages = messages + "Please install following missing utilities: %s\n" % missing
102
103         omask = os.umask(022)
104         if omask & 0755:
105                 messages = messages + "Please use a umask which allows a+rx and u+rwx\n"
106         os.umask(omask)
107
108         oes_bb_conf = data.getVar( 'OES_BITBAKE_CONF', e.data, True )
109         if not oes_bb_conf:
110                 messages = messages + 'You do not include OpenEmbeddeds version of conf/bitbake.conf\n'
111
112      # Check if the terminal has stty +tostop
113         if "tostop" in os.popen("stty").read():
114                 messages = messages + "You have tostop in your stty terminal setting. This will make BitBake hang when executing. Execute stty -tostop fix this.\n"
115  
116
117         if messages != "":
118                 raise_sanity_error(messages)
119
120 addhandler check_sanity_eventhandler
121 python check_sanity_eventhandler() {
122     from bb import note, error, data, __version__
123     from bb.event import getName
124
125     try:
126         from distutils.version import LooseVersion
127     except ImportError:
128         def LooseVersion(v): print "WARNING: sanity.bbclass can't compare versions without python-distutils"; return 1
129
130     if (LooseVersion(bb.__version__) > LooseVersion("1.8.6")):
131         if getName(e) == "ConfigParsed":
132             check_sanity(e)
133         return NotHandled
134
135     if getName(e) == "BuildStarted":
136         check_sanity(e)
137
138     return NotHandled
139 }