merge of '63c7ad87655c2781ad8b9c81af430596f48a24a6'
[vuplus_openembedded] / classes / sanity.bbclass
1 #
2 # Sanity check the users setup for common misconfigurations
3 #
4
5 def raise_sanity_error(msg):
6         import bb
7         bb.fatal(""" Openembedded's config sanity checker detected a potential misconfiguration.
8         Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
9         Following is the list of potential problems / advisories:
10         
11         %s""" % msg)
12
13 def check_conf_exists(fn, data):
14         import bb, os
15
16         bbpath = []
17         fn = bb.data.expand(fn, data)
18         vbbpath = bb.data.getVar("BBPATH", data)
19         if vbbpath:
20                 bbpath += vbbpath.split(":")
21         for p in bbpath:
22                 currname = os.path.join(bb.data.expand(p, data), fn)
23                 if os.access(currname, os.R_OK):
24                         return True
25         return False
26
27 def check_sanity(e):
28         from bb import note, error, data, __version__
29         from bb.event import Handled, NotHandled, getName
30         try:
31                 from distutils.version import LooseVersion
32         except ImportError:
33                 def LooseVersion(v): print "WARNING: sanity.bbclass can't compare versions without python-distutils"; return 1
34         import os
35
36         # Check the bitbake version meets minimum requirements
37         minversion = data.getVar('BB_MIN_VERSION', e.data , True)
38         if not minversion:
39                 # Hack: BB_MIN_VERSION hasn't been parsed yet so return 
40                 # and wait for the next call
41                 print "Foo %s" % minversion
42                 return
43
44         if 0 == os.getuid():
45                 raise_sanity_error("Do not use Bitbake as root.")
46
47         messages = ""
48
49         if (LooseVersion(__version__) < LooseVersion(minversion)):
50                 messages = messages + 'Bitbake version %s is required and version %s was found\n' % (minversion, __version__)
51
52         # Check TARGET_ARCH is set
53         if data.getVar('TARGET_ARCH', e.data, True) == 'INVALID':
54                 messages = messages + 'Please set TARGET_ARCH directly, or choose a MACHINE or DISTRO that does so.\n'
55         
56         # Check TARGET_OS is set
57         if data.getVar('TARGET_OS', e.data, True) == 'INVALID':
58                 messages = messages + 'Please set TARGET_OS directly, or choose a MACHINE or DISTRO that does so.\n'
59
60         assume_provided = data.getVar('ASSUME_PROVIDED', e.data , True).split()
61         # Check user doesn't have ASSUME_PROVIDED = instead of += in local.conf
62         if "diffstat-native" not in assume_provided:
63                 messages = messages + 'Please use ASSUME_PROVIDED +=, not ASSUME_PROVIDED = in your local.conf\n'
64         
65         # Check that the MACHINE is valid, if it is set
66         if data.getVar('MACHINE', e.data, True):
67             if not check_conf_exists("conf/machine/${MACHINE}.conf", e.data):
68                 messages = messages + 'Please set a valid MACHINE in your local.conf\n'
69         
70         # Check that the DISTRO is valid
71         # need to take into account DISTRO renaming DISTRO
72         if not ( check_conf_exists("conf/distro/${DISTRO}.conf", e.data) or check_conf_exists("conf/distro/include/${DISTRO}.inc", e.data) ):
73                 messages = messages + "DISTRO '%s' not found. Please set a valid DISTRO in your local.conf\n" % data.getVar("DISTRO", e.data, True )
74
75         missing = ""
76
77         if not check_app_exists("${MAKE}", e.data):
78                 missing = missing + "GNU make,"
79
80         if not check_app_exists('${BUILD_PREFIX}gcc', e.data):
81                 missing = missing + "C Compiler (${BUILD_PREFIX}gcc),"
82
83         if not check_app_exists('${BUILD_PREFIX}g++', e.data):
84                 missing = missing + "C++ Compiler (${BUILD_PREFIX}g++),"
85
86         required_utilities = "patch help2man diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk md5sum"
87
88         for util in required_utilities.split():
89                 if not check_app_exists( util, e.data ):
90                         missing = missing + "%s," % util
91
92         if missing != "":
93                 missing = missing.rstrip(',')
94                 messages = messages + "Please install following missing utilities: %s\n" % missing
95
96         omask = os.umask(022)
97         if omask & 0755:
98                 messages = messages + "Please use a umask which allows a+rx and u+rwx\n"
99         os.umask(omask)
100
101         oes_bb_conf = data.getVar( 'OES_BITBAKE_CONF', e.data, True )
102         if not oes_bb_conf:
103                 messages = messages + 'You do not include OpenEmbeddeds version of conf/bitbake.conf\n'
104
105         if messages != "":
106                 raise_sanity_error(messages)
107
108 addhandler check_sanity_eventhandler
109 python check_sanity_eventhandler() {
110     from bb import note, error, data, __version__
111     from bb.event import getName
112
113     try:
114         from distutils.version import LooseVersion
115     except ImportError:
116         def LooseVersion(v): print "WARNING: sanity.bbclass can't compare versions without python-distutils"; return 1
117
118     if (LooseVersion(bb.__version__) > LooseVersion("1.8.6")):
119         if getName(e) == "ConfigParsed":
120             check_sanity(e)
121         return NotHandled
122
123     if getName(e) == "BuildStarted":
124         check_sanity(e)
125
126     return NotHandled
127 }