merge of '2e75cbd37f40c36e60bc1e60a02e967304b6b338'
[vuplus_openembedded] / classes / pkgconfig.bbclass
1 inherit base
2
3 DEPENDS_prepend = "pkgconfig-native "
4
5 do_install_prepend () {
6
7 for i in `find ${S}/ -name "*.pc" -type f` ; do \
8             sed -i -e 's:-L${STAGING_LIBDIR}::g' $i
9         done
10 }
11
12 do_stage_append () {
13         install -d ${PKG_CONFIG_DIR}
14         for pc in `find ${S} -name '*.pc' -type f | grep -v -- '-uninstalled.pc$'`; do
15                 pcname=`basename $pc`
16                 cat $pc > ${PKG_CONFIG_DIR}/$pcname
17         done
18 }