merge of d23a51fd3de55ab7bd14228f1701651fb28530e6
[vuplus_openembedded] / classes / palmtop.bbclass
1 # this build class sets up qmake variables to
2 #   * build using the Qt Windowing System (QWS)
3 #   * use qt
4 #   * link against supc++ instead of stdc++  
5 #   * use threads, if requested via PALMTOP_USE_MULTITHREADED_QT = "yes"
6 # inherit this class to build programs against libqpe
7 # inherit opie if you want to build programs against libopie2
8
9 inherit qmake
10
11 EXTRA_QMAKEVARS_POST += "DEFINES+=QWS LIBS+=-lqpe CONFIG+=qt LIBS-=-lstdc++ LIBS+=-lsupc++"
12 EXTRA_QMAKEVARS_POST += '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "CONFIG+=thread", " ",d)}'
13
14 DEPENDS_prepend = "${@["virtual/libqpe1 uicmoc-native ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
15
16 FILES_${PN} = "${palmtopdir}"