merge of 0b5d6ed48b6bbd6c6c562be67f6b8f51f55433c0
[vuplus_openembedded] / classes / palmtop.bbclass
1 # this build class sets up qmake variables to
2 #   * build using the Qt Windowing System (QWS)
3 #   * use qt
4 #   * link against supc++ instead of stdc++  
5 #   * use threads, if requested via PALMTOP_USE_MULTITHREADED_QT = "yes"
6 # inherit this class to build programs against libqpe
7 # inherit opie if you want to build programs against libopie2
8
9 inherit qmake
10
11 EXTRA_QMAKEVARS_POST += "DEFINES+=QWS LIBS+=-lqpe CONFIG+=qt LIBS-=-lstdc++ LIBS+=-lsupc++"
12 EXTRA_QMAKEVARS_POST += "${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "CONFIG+=thread", "",d)}'
13
14 DEPENDS_prepend = "virtual/libqpe1 uicmoc-native "
15
16 FILES_${PN} = "${palmtopdir}"