palmtop.bbclass: say CONFIG-=thread if we don't build against a multithreaded qt
[vuplus_openembedded] / classes / palmtop.bbclass
1 # this build class sets up qmake variables to
2 #   * build using the Qt Windowing System (QWS)
3 #   * use qt
4 #   * link against supc++ instead of stdc++  
5 #   * use threads, if requested via PALMTOP_USE_MULTITHREADED_QT = "yes"
6 # inherit this class to build programs against libqpe
7 # inherit opie if you want to build programs against libopie2
8 # don't override EXTRA_QMAKEVARS_POST, if you use inherit this class
9
10 inherit qmake
11
12 EXTRA_QMAKEVARS_POST += "DEFINES+=QWS CONFIG+=qt LIBS-=-lstdc++ LIBS+=-lsupc++"
13 EXTRA_QMAKEVARS_POST += '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "CONFIG+=thread", "CONFIG-=thread",d)}'
14 EXTRA_QMAKEVARS_POST += "${@["LIBS+=-lqpe ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
15 DEPENDS_prepend = "${@["virtual/libqpe1 uicmoc-native ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
16
17 FILES_${PN} = "${palmtopdir}"