merge of 'aac60b186b977130a688c4d00bfde913fb6221eb'
[vuplus_openembedded] / classes / package_ipk.bbclass
1 inherit package
2
3 BOOTSTRAP_EXTRA_RDEPENDS += "ipkg-collateral ipkg"
4 IMAGE_PKGTYPE ?= "ipk"
5
6 IPKGCONF_TARGET = "${STAGING_ETCDIR_NATIVE}/ipkg.conf"
7 IPKGCONF_SDK =  "${STAGING_ETCDIR_NATIVE}/ipkg-sdk.conf"
8
9 python package_ipk_fn () {
10         from bb import data
11         bb.data.setVar('PKGFN', bb.data.getVar('PKG',d), d)
12 }
13
14 python package_ipk_install () {
15         import os, sys
16         pkg = bb.data.getVar('PKG', d, 1)
17         pkgfn = bb.data.getVar('PKGFN', d, 1)
18         rootfs = bb.data.getVar('IMAGE_ROOTFS', d, 1)
19         ipkdir = bb.data.getVar('DEPLOY_DIR_IPK', d, 1)
20         stagingdir = bb.data.getVar('STAGING_DIR', d, 1)
21         tmpdir = bb.data.getVar('TMPDIR', d, 1)
22
23         if None in (pkg,pkgfn,rootfs):
24                 raise bb.build.FuncFailed("missing variables (one or more of PKG, PKGFN, IMAGEROOTFS)")
25         try:
26                 bb.mkdirhier(rootfs)
27                 os.chdir(rootfs)
28         except OSError:
29                 (type, value, traceback) = sys.exc_info()
30                 print value
31                 raise bb.build.FuncFailed
32
33         # Generate ipk.conf if it or the stamp doesnt exist
34         conffile = os.path.join(stagingdir,"ipkg.conf")
35         if not  os.access(conffile, os.R_OK):
36                 ipkg_archs = bb.data.getVar('PACKAGE_ARCHS',d)
37                 if ipkg_archs is None:
38                         bb.error("PACKAGE_ARCHS missing")
39                         raise FuncFailed
40                 ipkg_archs = ipkg_archs.split()
41                 arch_priority = 1
42
43                 f = open(conffile,"w")
44                 for arch in ipkg_archs:
45                         f.write("arch %s %s\n" % ( arch, arch_priority ))
46                         arch_priority += 1
47                 f.write("src local file:%s" % ipkdir)
48                 f.close()
49
50
51         if (not os.access(os.path.join(ipkdir,"Packages"), os.R_OK) or
52                 not os.access(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"),os.R_OK):
53                 ret = os.system('ipkg-make-index -p %s %s ' % (os.path.join(ipkdir, "Packages"), ipkdir))
54                 if (ret != 0 ):
55                         raise bb.build.FuncFailed
56                 f = open(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"),"w")
57                 f.close()
58
59         ret = os.system('ipkg-cl  -o %s -f %s update' % (rootfs, conffile))
60         ret = os.system('ipkg-cl  -o %s -f %s install %s' % (rootfs, conffile, pkgfn))
61         if (ret != 0 ):
62                 raise bb.build.FuncFailed
63 }
64
65 #
66 # Update the Packages index files in ${DEPLOY_DIR_IPK}
67 #
68 package_update_index_ipk () {
69         set -x
70
71         ipkgarchs="${PACKAGE_ARCHS}"
72
73         if [ ! -z "${DEPLOY_KEEP_PACKAGES}" ]; then
74                 return
75         fi
76
77         touch ${DEPLOY_DIR_IPK}/Packages
78         ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
79
80         for arch in $ipkgarchs; do
81                 if [ -e ${DEPLOY_DIR_IPK}/$arch/ ] ; then 
82                         touch ${DEPLOY_DIR_IPK}/$arch/Packages
83                         ipkg-make-index -r ${DEPLOY_DIR_IPK}/$arch/Packages -p ${DEPLOY_DIR_IPK}/$arch/Packages -l ${DEPLOY_DIR_IPK}/$arch/Packages.filelist -m ${DEPLOY_DIR_IPK}/$arch/
84                 fi
85                 if [ -e ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/ ] ; then 
86                         touch ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages
87                         ipkg-make-index -r ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -p ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -l ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages.filelist -m ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/
88                 fi
89         done
90 }
91
92 #
93 # Generate an ipkg conf file ${IPKGCONF_TARGET} suitable for use against 
94 # the target system and an ipkg conf file ${IPKGCONF_SDK} suitable for 
95 # use against the host system in sdk builds
96 #
97 package_generate_ipkg_conf () {
98         mkdir -p ${STAGING_ETCDIR_NATIVE}/
99         echo "src oe file:${DEPLOY_DIR_IPK}" > ${IPKGCONF_TARGET}
100         echo "src oe file:${DEPLOY_DIR_IPK}" > ${IPKGCONF_SDK}
101         ipkgarchs="${PACKAGE_ARCHS}"
102         priority=1
103         for arch in $ipkgarchs; do
104                 echo "arch $arch $priority" >> ${IPKGCONF_TARGET}
105                 echo "arch ${BUILD_ARCH}-$arch-sdk $priority" >> ${IPKGCONF_SDK}
106                 priority=$(expr $priority + 5)
107                 if [ -e ${DEPLOY_DIR_IPK}/$arch/Packages ] ; then
108                         echo "src oe-$arch file:${DEPLOY_DIR_IPK}/$arch" >> ${IPKGCONF_TARGET}
109                 fi
110                 if [ -e ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages ] ; then
111                         echo "src oe-${BUILD_ARCH}-$arch-sdk file:${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk" >> ${IPKGCONF_SDK}
112                 fi
113         done
114 }
115
116 python do_package_ipk () {
117         import sys, re, fcntl, copy
118
119         workdir = bb.data.getVar('WORKDIR', d, 1)
120         if not workdir:
121                 bb.error("WORKDIR not defined, unable to package")
122                 return
123
124         import os # path manipulations
125         outdir = bb.data.getVar('DEPLOY_DIR_IPK', d, 1)
126         if not outdir:
127                 bb.error("DEPLOY_DIR_IPK not defined, unable to package")
128                 return
129
130         arch = bb.data.getVar('PACKAGE_ARCH', d, 1)
131         outdir = "%s/%s" % (outdir, arch)
132         bb.mkdirhier(outdir)
133
134         dvar = bb.data.getVar('D', d, 1)
135         if not dvar:
136                 bb.error("D not defined, unable to package")
137                 return
138         bb.mkdirhier(dvar)
139
140         packages = bb.data.getVar('PACKAGES', d, 1)
141         if not packages:
142                 bb.debug(1, "PACKAGES not defined, nothing to package")
143                 return
144
145         tmpdir = bb.data.getVar('TMPDIR', d, 1)
146
147         if os.access(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"), os.R_OK):
148                 os.unlink(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"))
149
150         if packages == []:
151                 bb.debug(1, "No packages; nothing to do")
152                 return
153
154         def lockfile(name):
155                 lf = open(name, "a+")
156                 fcntl.flock(lf.fileno(), fcntl.LOCK_EX)
157                 return lf
158
159         def unlockfile(lf):
160                 fcntl.flock(lf.fileno(), fcntl.LOCK_UN)
161                 lf.close
162
163         for pkg in packages.split():
164                 localdata = bb.data.createCopy(d)
165                 root = "%s/install/%s" % (workdir, pkg)
166
167                 lf = lockfile(root + ".lock")
168
169                 bb.data.setVar('ROOT', '', localdata)
170                 bb.data.setVar('ROOT_%s' % pkg, root, localdata)
171                 pkgname = bb.data.getVar('PKG_%s' % pkg, localdata, 1)
172                 if not pkgname:
173                         pkgname = pkg
174                 bb.data.setVar('PKG', pkgname, localdata)
175
176                 overrides = bb.data.getVar('OVERRIDES', localdata)
177                 if not overrides:
178                         raise bb.build.FuncFailed('OVERRIDES not defined')
179                 overrides = bb.data.expand(overrides, localdata)
180                 bb.data.setVar('OVERRIDES', overrides + ':' + pkg, localdata)
181
182                 bb.data.update_data(localdata)
183                 basedir = os.path.join(os.path.dirname(root))
184                 pkgoutdir = outdir
185                 bb.mkdirhier(pkgoutdir)
186                 os.chdir(root)
187                 from glob import glob
188                 g = glob('*')
189                 try:
190                         del g[g.index('CONTROL')]
191                         del g[g.index('./CONTROL')]
192                 except ValueError:
193                         pass
194                 if not g and bb.data.getVar('ALLOW_EMPTY', localdata) != "1":
195                         from bb import note
196                         note("Not creating empty archive for %s-%s-%s" % (pkg, bb.data.getVar('PV', localdata, 1), bb.data.getVar('PR', localdata, 1)))
197                         unlockfile(lf)
198                         continue
199
200                 controldir = os.path.join(root, 'CONTROL')
201                 bb.mkdirhier(controldir)
202                 try:
203                         ctrlfile = file(os.path.join(controldir, 'control'), 'w')
204                 except OSError:
205                         raise bb.build.FuncFailed("unable to open control file for writing.")
206
207                 fields = []
208                 pe = bb.data.getVar('PE', d, 1)
209                 if pe and int(pe) > 0:
210                         fields.append(["Version: %s:%s-%s\n", ['PE', 'PV', 'PR']])
211                 else:
212                         fields.append(["Version: %s-%s\n", ['PV', 'PR']])
213                 fields.append(["Description: %s\n", ['DESCRIPTION']])
214                 fields.append(["Section: %s\n", ['SECTION']])
215                 fields.append(["Priority: %s\n", ['PRIORITY']])
216                 fields.append(["Maintainer: %s\n", ['MAINTAINER']])
217                 fields.append(["Architecture: %s\n", ['PACKAGE_ARCH']])
218                 fields.append(["OE: %s\n", ['PN']])
219                 fields.append(["Homepage: %s\n", ['HOMEPAGE']])
220
221                 def pullData(l, d):
222                         l2 = []
223                         for i in l:
224                                 l2.append(bb.data.getVar(i, d, 1))
225                         return l2
226
227                 ctrlfile.write("Package: %s\n" % pkgname)
228                 # check for required fields
229                 try:
230                         for (c, fs) in fields:
231                                 for f in fs:
232                                         if bb.data.getVar(f, localdata) is None:
233                                                 raise KeyError(f)
234                                 ctrlfile.write(c % tuple(pullData(fs, localdata)))
235                 except KeyError:
236                         (type, value, traceback) = sys.exc_info()
237                         ctrlfile.close()
238                         raise bb.build.FuncFailed("Missing field for ipk generation: %s" % value)
239                 # more fields
240
241                 bb.build.exec_func("mapping_rename_hook", localdata)
242
243                 rdepends = explode_deps(bb.data.getVar("RDEPENDS", localdata, 1) or "")
244                 rrecommends = explode_deps(bb.data.getVar("RRECOMMENDS", localdata, 1) or "")
245                 rsuggests = (bb.data.getVar("RSUGGESTS", localdata, 1) or "").split()
246                 rprovides = (bb.data.getVar("RPROVIDES", localdata, 1) or "").split()
247                 rreplaces = (bb.data.getVar("RREPLACES", localdata, 1) or "").split()
248                 rconflicts = (bb.data.getVar("RCONFLICTS", localdata, 1) or "").split()
249                 if rdepends:
250                         ctrlfile.write("Depends: %s\n" % ", ".join(rdepends))
251                 if rsuggests:
252                         ctrlfile.write("Suggests: %s\n" % ", ".join(rsuggests))
253                 if rrecommends:
254                         ctrlfile.write("Recommends: %s\n" % ", ".join(rrecommends))
255                 if rprovides:
256                         ctrlfile.write("Provides: %s\n" % ", ".join(rprovides))
257                 if rreplaces:
258                         ctrlfile.write("Replaces: %s\n" % ", ".join(rreplaces))
259                 if rconflicts:
260                         ctrlfile.write("Conflicts: %s\n" % ", ".join(rconflicts))
261                 src_uri = bb.data.getVar("SRC_URI", localdata, 1)
262                 if src_uri:
263                         src_uri = re.sub("\s+", " ", src_uri)
264                         ctrlfile.write("Source: %s\n" % " ".join(src_uri.split()))
265                 ctrlfile.close()
266
267                 for script in ["preinst", "postinst", "prerm", "postrm"]:
268                         scriptvar = bb.data.getVar('pkg_%s' % script, localdata, 1)
269                         if not scriptvar:
270                                 continue
271                         try:
272                                 scriptfile = file(os.path.join(controldir, script), 'w')
273                         except OSError:
274                                 raise bb.build.FuncFailed("unable to open %s script file for writing." % script)
275                         scriptfile.write(scriptvar)
276                         scriptfile.close()
277                         os.chmod(os.path.join(controldir, script), 0755)
278
279                 conffiles_str = bb.data.getVar("CONFFILES", localdata, 1)
280                 if conffiles_str:
281                         try:
282                                 conffiles = file(os.path.join(controldir, 'conffiles'), 'w')
283                         except OSError:
284                                 raise bb.build.FuncFailed("unable to open conffiles for writing.")
285                         for f in conffiles_str.split():
286                                 conffiles.write('%s\n' % f)
287                         conffiles.close()
288
289                 os.chdir(basedir)
290                 ret = os.system("PATH=\"%s\" %s %s %s" % (bb.data.getVar("PATH", localdata, 1), 
291                                                           bb.data.getVar("IPKGBUILDCMD",d,1), pkg, pkgoutdir))
292                 if ret != 0:
293                         raise bb.build.FuncFailed("ipkg-build execution failed")
294
295                 for script in ["preinst", "postinst", "prerm", "postrm", "control" ]:
296                         scriptfile = os.path.join(controldir, script)
297                         try:
298                                 os.remove(scriptfile)
299                         except OSError:
300                                 pass
301                 try:
302                         os.rmdir(controldir)
303                 except OSError:
304                         pass
305                 unlockfile(lf)
306 }
307
308 python () {
309     import bb
310     if bb.data.getVar('PACKAGES', d, True) != '':
311         bb.data.setVarFlag('do_package_write_ipk', 'depends', 'ipkg-utils-native:do_populate_staging fakeroot-native:do_populate_staging', d)
312 }
313
314 python do_package_write_ipk () {
315         bb.build.exec_func("read_subpackage_metadata", d)
316         bb.build.exec_func("do_package_ipk", d)
317 }
318 do_package_write_ipk[dirs] = "${D}"
319 addtask package_write_ipk before do_package_write after do_package