merge of '1da81118402f312c1b90e65968cd0a7f76696542'
[vuplus_openembedded] / classes / package_ipk.bbclass
1 inherit package
2
3 BOOTSTRAP_EXTRA_RDEPENDS += "ipkg-collateral ipkg"
4 IMAGE_PKGTYPE ?= "ipk"
5
6 IPKGCONF_TARGET = "${STAGING_ETCDIR_NATIVE}/ipkg.conf"
7 IPKGCONF_SDK =  "${STAGING_ETCDIR_NATIVE}/ipkg-sdk.conf"
8
9 python package_ipk_fn () {
10         from bb import data
11         bb.data.setVar('PKGFN', bb.data.getVar('PKG',d), d)
12 }
13
14 python package_ipk_install () {
15         import os, sys
16         pkg = bb.data.getVar('PKG', d, 1)
17         pkgfn = bb.data.getVar('PKGFN', d, 1)
18         rootfs = bb.data.getVar('IMAGE_ROOTFS', d, 1)
19         ipkdir = bb.data.getVar('DEPLOY_DIR_IPK', d, 1)
20         stagingdir = bb.data.getVar('STAGING_DIR', d, 1)
21         tmpdir = bb.data.getVar('TMPDIR', d, 1)
22
23         if None in (pkg,pkgfn,rootfs):
24                 raise bb.build.FuncFailed("missing variables (one or more of PKG, PKGFN, IMAGEROOTFS)")
25         try:
26                 bb.mkdirhier(rootfs)
27                 os.chdir(rootfs)
28         except OSError:
29                 (type, value, traceback) = sys.exc_info()
30                 print value
31                 raise bb.build.FuncFailed
32
33         # Generate ipk.conf if it or the stamp doesnt exist
34         conffile = os.path.join(stagingdir,"ipkg.conf")
35         if not os.access(conffile, os.R_OK):
36                 ipkg_archs = bb.data.getVar('PACKAGE_ARCHS',d)
37                 if ipkg_archs is None:
38                         bb.error("PACKAGE_ARCHS missing")
39                         raise FuncFailed
40                 ipkg_archs = ipkg_archs.split()
41                 arch_priority = 1
42
43                 f = open(conffile,"w")
44                 for arch in ipkg_archs:
45                         f.write("arch %s %s\n" % ( arch, arch_priority ))
46                         arch_priority += 1
47                 f.write("src local file:%s" % ipkdir)
48                 f.close()
49
50
51         if (not os.access(os.path.join(ipkdir,"Packages"), os.R_OK) or
52                 not os.access(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"),os.R_OK):
53                 ret = os.system('ipkg-make-index -p %s %s ' % (os.path.join(ipkdir, "Packages"), ipkdir))
54                 if (ret != 0 ):
55                         raise bb.build.FuncFailed
56                 f = open(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"),"w")
57                 f.close()
58
59         ret = os.system('ipkg-cl  -o %s -f %s update' % (rootfs, conffile))
60         ret = os.system('ipkg-cl  -o %s -f %s install %s' % (rootfs, conffile, pkgfn))
61         if (ret != 0 ):
62                 raise bb.build.FuncFailed
63 }
64
65 #
66 # Update the Packages index files in ${DEPLOY_DIR_IPK}
67 #
68 package_update_index_ipk () {
69         set -x
70
71         ipkgarchs="${PACKAGE_ARCHS}"
72
73         if [ ! -z "${DEPLOY_KEEP_PACKAGES}" ]; then
74                 return
75         fi
76
77         touch ${DEPLOY_DIR_IPK}/Packages
78         ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
79
80         for arch in $ipkgarchs; do
81                 if [ -e ${DEPLOY_DIR_IPK}/$arch/ ] ; then 
82                         touch ${DEPLOY_DIR_IPK}/$arch/Packages
83                         ipkg-make-index -r ${DEPLOY_DIR_IPK}/$arch/Packages -p ${DEPLOY_DIR_IPK}/$arch/Packages -l ${DEPLOY_DIR_IPK}/$arch/Packages.filelist -m ${DEPLOY_DIR_IPK}/$arch/
84                 fi
85                 if [ -e ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/ ] ; then 
86                         touch ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages
87                         ipkg-make-index -r ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -p ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -l ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages.filelist -m ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/
88                 fi
89         done
90 }
91
92 #
93 # Generate an ipkg conf file ${IPKGCONF_TARGET} suitable for use against 
94 # the target system and an ipkg conf file ${IPKGCONF_SDK} suitable for 
95 # use against the host system in sdk builds
96 #
97 package_generate_ipkg_conf () {
98         mkdir -p ${STAGING_ETCDIR_NATIVE}/
99         echo "src oe file:${DEPLOY_DIR_IPK}" > ${IPKGCONF_TARGET}
100         echo "src oe file:${DEPLOY_DIR_IPK}" > ${IPKGCONF_SDK}
101         ipkgarchs="${PACKAGE_ARCHS}"
102         priority=1
103         for arch in $ipkgarchs; do
104                 echo "arch $arch $priority" >> ${IPKGCONF_TARGET}
105                 echo "arch ${BUILD_ARCH}-$arch-sdk $priority" >> ${IPKGCONF_SDK}
106                 priority=$(expr $priority + 5)
107                 if [ -e ${DEPLOY_DIR_IPK}/$arch/Packages ] ; then
108                         echo "src oe-$arch file:${DEPLOY_DIR_IPK}/$arch" >> ${IPKGCONF_TARGET}
109                 fi
110                 if [ -e ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages ] ; then
111                         echo "src oe-${BUILD_ARCH}-$arch-sdk file:${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk" >> ${IPKGCONF_SDK}
112                 fi
113         done
114 }
115
116 python do_package_ipk () {
117         import sys, re, copy, fcntl
118
119         workdir = bb.data.getVar('WORKDIR', d, 1)
120         if not workdir:
121                 bb.error("WORKDIR not defined, unable to package")
122                 return
123
124         import os # path manipulations
125         outdir = bb.data.getVar('DEPLOY_DIR_IPK', d, 1)
126         if not outdir:
127                 bb.error("DEPLOY_DIR_IPK not defined, unable to package")
128                 return
129
130         dvar = bb.data.getVar('D', d, 1)
131         if not dvar:
132                 bb.error("D not defined, unable to package")
133                 return
134         bb.mkdirhier(dvar)
135
136         packages = bb.data.getVar('PACKAGES', d, 1)
137         if not packages:
138                 bb.debug(1, "PACKAGES not defined, nothing to package")
139                 return
140
141         tmpdir = bb.data.getVar('TMPDIR', d, 1)
142
143         if os.access(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"), os.R_OK):
144                 os.unlink(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"))
145
146         if packages == []:
147                 bb.debug(1, "No packages; nothing to do")
148                 return
149
150         def lockfile(name):
151                 lf = open(name, "a+")
152                 fcntl.flock(lf.fileno(), fcntl.LOCK_EX)
153                 return lf
154
155         def unlockfile(lf):
156                 fcntl.flock(lf.fileno(), fcntl.LOCK_UN)
157                 lf.close
158
159
160         for pkg in packages.split():
161                 localdata = bb.data.createCopy(d)
162                 pkgdest = bb.data.getVar('PKGDEST', d, 1)
163                 root = "%s/%s" % (pkgdest, pkg)
164
165                 lf = lockfile(root + ".lock")
166
167                 bb.data.setVar('ROOT', '', localdata)
168                 bb.data.setVar('ROOT_%s' % pkg, root, localdata)
169                 pkgname = bb.data.getVar('PKG_%s' % pkg, localdata, 1)
170                 if not pkgname:
171                         pkgname = pkg
172                 bb.data.setVar('PKG', pkgname, localdata)
173
174                 overrides = bb.data.getVar('OVERRIDES', localdata)
175                 if not overrides:
176                         raise bb.build.FuncFailed('OVERRIDES not defined')
177                 overrides = bb.data.expand(overrides, localdata)
178                 bb.data.setVar('OVERRIDES', overrides + ':' + pkg, localdata)
179
180                 bb.data.update_data(localdata)
181                 basedir = os.path.join(os.path.dirname(root))
182                 arch = bb.data.getVar('PACKAGE_ARCH', localdata, 1)
183                 pkgoutdir = "%s/%s" % (outdir, arch)
184                 bb.mkdirhier(pkgoutdir)
185                 os.chdir(root)
186                 from glob import glob
187                 g = glob('*')
188                 try:
189                         del g[g.index('CONTROL')]
190                         del g[g.index('./CONTROL')]
191                 except ValueError:
192                         pass
193                 if not g and bb.data.getVar('ALLOW_EMPTY', localdata) != "1":
194                         from bb import note
195                         note("Not creating empty archive for %s-%s-%s" % (pkg, bb.data.getVar('PV', localdata, 1), bb.data.getVar('PR', localdata, 1)))
196                         unlockfile(lf)
197                         continue
198
199                 controldir = os.path.join(root, 'CONTROL')
200                 bb.mkdirhier(controldir)
201                 try:
202                         ctrlfile = file(os.path.join(controldir, 'control'), 'w')
203                 except OSError:
204                         unlockfile(lf)
205                         raise bb.build.FuncFailed("unable to open control file for writing.")
206
207                 fields = []
208                 pe = bb.data.getVar('PE', d, 1)
209                 if pe and int(pe) > 0:
210                         fields.append(["Version: %s:%s-%s\n", ['PE', 'PV', 'PR']])
211                 else:
212                         fields.append(["Version: %s-%s\n", ['PV', 'PR']])
213                 fields.append(["Description: %s\n", ['DESCRIPTION']])
214                 fields.append(["Section: %s\n", ['SECTION']])
215                 fields.append(["Priority: %s\n", ['PRIORITY']])
216                 fields.append(["Maintainer: %s\n", ['MAINTAINER']])
217                 fields.append(["Architecture: %s\n", ['PACKAGE_ARCH']])
218                 fields.append(["OE: %s\n", ['PN']])
219                 fields.append(["Homepage: %s\n", ['HOMEPAGE']])
220
221                 def pullData(l, d):
222                         l2 = []
223                         for i in l:
224                                 l2.append(bb.data.getVar(i, d, 1))
225                         return l2
226
227                 ctrlfile.write("Package: %s\n" % pkgname)
228                 # check for required fields
229                 try:
230                         for (c, fs) in fields:
231                                 for f in fs:
232                                         if bb.data.getVar(f, localdata) is None:
233                                                 raise KeyError(f)
234                                 ctrlfile.write(c % tuple(pullData(fs, localdata)))
235                 except KeyError:
236                         (type, value, traceback) = sys.exc_info()
237                         ctrlfile.close()
238                         unlockfile(lf)
239                         raise bb.build.FuncFailed("Missing field for ipk generation: %s" % value)
240                 # more fields
241
242                 bb.build.exec_func("mapping_rename_hook", localdata)
243
244                 rdepends = explode_deps(bb.data.getVar("RDEPENDS", localdata, 1) or "")
245                 rrecommends = explode_deps(bb.data.getVar("RRECOMMENDS", localdata, 1) or "")
246                 rsuggests = (bb.data.getVar("RSUGGESTS", localdata, 1) or "").split()
247                 rprovides = (bb.data.getVar("RPROVIDES", localdata, 1) or "").split()
248                 rreplaces = (bb.data.getVar("RREPLACES", localdata, 1) or "").split()
249                 rconflicts = (bb.data.getVar("RCONFLICTS", localdata, 1) or "").split()
250                 if rdepends:
251                         ctrlfile.write("Depends: %s\n" % ", ".join(rdepends))
252                 if rsuggests:
253                         ctrlfile.write("Suggests: %s\n" % ", ".join(rsuggests))
254                 if rrecommends:
255                         ctrlfile.write("Recommends: %s\n" % ", ".join(rrecommends))
256                 if rprovides:
257                         ctrlfile.write("Provides: %s\n" % ", ".join(rprovides))
258                 if rreplaces:
259                         ctrlfile.write("Replaces: %s\n" % ", ".join(rreplaces))
260                 if rconflicts:
261                         ctrlfile.write("Conflicts: %s\n" % ", ".join(rconflicts))
262                 src_uri = bb.data.getVar("SRC_URI", localdata, 1)
263                 if src_uri:
264                         src_uri = re.sub("\s+", " ", src_uri)
265                         ctrlfile.write("Source: %s\n" % " ".join(src_uri.split()))
266                 ctrlfile.close()
267
268                 for script in ["preinst", "postinst", "prerm", "postrm"]:
269                         scriptvar = bb.data.getVar('pkg_%s' % script, localdata, 1)
270                         if not scriptvar:
271                                 continue
272                         try:
273                                 scriptfile = file(os.path.join(controldir, script), 'w')
274                         except OSError:
275                                 unlockfile(lf)
276                                 raise bb.build.FuncFailed("unable to open %s script file for writing." % script)
277                         scriptfile.write(scriptvar)
278                         scriptfile.close()
279                         os.chmod(os.path.join(controldir, script), 0755)
280
281                 conffiles_str = bb.data.getVar("CONFFILES", localdata, 1)
282                 if conffiles_str:
283                         try:
284                                 conffiles = file(os.path.join(controldir, 'conffiles'), 'w')
285                         except OSError:
286                                 unlockfile(lf)
287                                 raise bb.build.FuncFailed("unable to open conffiles for writing.")
288                         for f in conffiles_str.split():
289                                 conffiles.write('%s\n' % f)
290                         conffiles.close()
291
292                 os.chdir(basedir)
293                 ret = os.system("PATH=\"%s\" %s %s %s" % (bb.data.getVar("PATH", localdata, 1), 
294                                                           bb.data.getVar("IPKGBUILDCMD",d,1), pkg, pkgoutdir))
295                 if ret != 0:
296                         unlockfile(lf)
297                         raise bb.build.FuncFailed("ipkg-build execution failed")
298
299                 for script in ["preinst", "postinst", "prerm", "postrm", "control" ]:
300                         scriptfile = os.path.join(controldir, script)
301                         try:
302                                 os.remove(scriptfile)
303                         except OSError:
304                                 pass
305                 try:
306                         os.rmdir(controldir)
307                 except OSError:
308                         pass
309                 unlockfile(lf)
310 }
311
312 python () {
313     import bb
314     if bb.data.getVar('PACKAGES', d, True) != '':
315         deps = (bb.data.getVarFlag('do_package_write_ipk', 'depends', d) or "").split()
316         deps.append('ipkg-utils-native:do_populate_staging')
317         deps.append('fakeroot-native:do_populate_staging')
318         bb.data.setVarFlag('do_package_write_ipk', 'depends', " ".join(deps), d)
319 }
320
321 python do_package_write_ipk () {
322         bb.build.exec_func("read_subpackage_metadata", d)
323         bb.build.exec_func("do_package_ipk", d)
324 }
325 do_package_write_ipk[dirs] = "${D}"
326 do_package_write_ipk[depends] = "ipkg-utils-native:do_populate_staging"
327 addtask package_write_ipk before do_package_write after do_package