merge of '0b604857bbf871639fdb43ee8380222e8ef64bb7'
[vuplus_openembedded] / classes / package_ipk.bbclass
1 inherit package
2
3 BOOTSTRAP_EXTRA_RDEPENDS += "opkg-collateral opkg"
4 IMAGE_PKGTYPE ?= "ipk"
5
6 IPKGCONF_TARGET = "${STAGING_ETCDIR_NATIVE}/opkg.conf"
7 IPKGCONF_SDK =  "${STAGING_ETCDIR_NATIVE}/opkg-sdk.conf"
8
9 python package_ipk_fn () {
10         from bb import data
11         bb.data.setVar('PKGFN', bb.data.getVar('PKG',d), d)
12 }
13
14 python package_ipk_install () { 
15         #
16         # Warning - this function is not multimachine safe (see stagingdir reference)!
17         #
18
19         import os, sys
20         pkg = bb.data.getVar('PKG', d, 1)
21         pkgfn = bb.data.getVar('PKGFN', d, 1)
22         rootfs = bb.data.getVar('IMAGE_ROOTFS', d, 1)
23         ipkdir = bb.data.getVar('DEPLOY_DIR_IPK', d, 1)
24         stagingdir = bb.data.getVar('STAGING_DIR', d, 1)
25         tmpdir = bb.data.getVar('TMPDIR', d, 1)
26
27         if None in (pkg,pkgfn,rootfs):
28                 raise bb.build.FuncFailed("missing variables (one or more of PKG, PKGFN, IMAGEROOTFS)")
29         try:
30                 bb.mkdirhier(rootfs)
31                 os.chdir(rootfs)
32         except OSError:
33                 (type, value, traceback) = sys.exc_info()
34                 print value
35                 raise bb.build.FuncFailed
36
37         # Generate ipk.conf if it or the stamp doesnt exist
38         conffile = os.path.join(stagingdir,"opkg.conf")
39         if not os.access(conffile, os.R_OK):
40                 ipkg_archs = bb.data.getVar('PACKAGE_ARCHS',d)
41                 if ipkg_archs is None:
42                         bb.error("PACKAGE_ARCHS missing")
43                         raise FuncFailed
44                 ipkg_archs = ipkg_archs.split()
45                 arch_priority = 1
46
47                 f = open(conffile,"w")
48                 for arch in ipkg_archs:
49                         f.write("arch %s %s\n" % ( arch, arch_priority ))
50                         arch_priority += 1
51                 f.write("src local file:%s" % ipkdir)
52                 f.close()
53
54
55         if (not os.access(os.path.join(ipkdir,"Packages"), os.R_OK) or
56                 not os.access(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"),os.R_OK):
57                 ret = os.system('ipkg-make-index -p %s %s ' % (os.path.join(ipkdir, "Packages"), ipkdir))
58                 if (ret != 0 ):
59                         raise bb.build.FuncFailed
60                 f = open(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"),"w")
61                 f.close()
62
63         ret = os.system('opkg-cl  -o %s -f %s update' % (rootfs, conffile))
64         ret = os.system('opkg-cl  -o %s -f %s install %s' % (rootfs, conffile, pkgfn))
65         if (ret != 0 ):
66                 raise bb.build.FuncFailed
67 }
68
69 #
70 # Update the Packages index files in ${DEPLOY_DIR_IPK}
71 #
72 package_update_index_ipk () {
73         set -x
74
75         ipkgarchs="${PACKAGE_ARCHS}"
76
77         if [ ! -z "${DEPLOY_KEEP_PACKAGES}" ]; then
78                 return
79         fi
80
81         touch ${DEPLOY_DIR_IPK}/Packages
82         ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
83
84         for arch in $ipkgarchs; do
85                 if [ -e ${DEPLOY_DIR_IPK}/$arch/ ] ; then 
86                         touch ${DEPLOY_DIR_IPK}/$arch/Packages
87                         ipkg-make-index -r ${DEPLOY_DIR_IPK}/$arch/Packages -p ${DEPLOY_DIR_IPK}/$arch/Packages -l ${DEPLOY_DIR_IPK}/$arch/Packages.filelist -m ${DEPLOY_DIR_IPK}/$arch/
88                 fi
89                 if [ -e ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/ ] ; then 
90                         touch ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages
91                         ipkg-make-index -r ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -p ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages -l ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages.filelist -m ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/
92                 fi
93         done
94 }
95
96 #
97 # Generate an ipkg conf file ${IPKGCONF_TARGET} suitable for use against 
98 # the target system and an ipkg conf file ${IPKGCONF_SDK} suitable for 
99 # use against the host system in sdk builds
100 #
101 package_generate_ipkg_conf () {
102         mkdir -p ${STAGING_ETCDIR_NATIVE}/
103         echo "src oe file:${DEPLOY_DIR_IPK}" > ${IPKGCONF_TARGET}
104         echo "src oe file:${DEPLOY_DIR_IPK}" > ${IPKGCONF_SDK}
105         ipkgarchs="${PACKAGE_ARCHS}"
106         priority=1
107         for arch in $ipkgarchs; do
108                 echo "arch $arch $priority" >> ${IPKGCONF_TARGET}
109                 echo "arch ${BUILD_ARCH}-$arch-sdk $priority" >> ${IPKGCONF_SDK}
110                 priority=$(expr $priority + 5)
111                 if [ -e ${DEPLOY_DIR_IPK}/$arch/Packages ] ; then
112                         echo "src oe-$arch file:${DEPLOY_DIR_IPK}/$arch" >> ${IPKGCONF_TARGET}
113                 fi
114                 if [ -e ${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk/Packages ] ; then
115                         echo "src oe-${BUILD_ARCH}-$arch-sdk file:${DEPLOY_DIR_IPK}/${BUILD_ARCH}-$arch-sdk" >> ${IPKGCONF_SDK}
116                 fi
117         done
118 }
119
120 python do_package_ipk () {
121         import sys, re, copy
122
123         workdir = bb.data.getVar('WORKDIR', d, 1)
124         if not workdir:
125                 bb.error("WORKDIR not defined, unable to package")
126                 return
127
128         import os # path manipulations
129         outdir = bb.data.getVar('DEPLOY_DIR_IPK', d, 1)
130         if not outdir:
131                 bb.error("DEPLOY_DIR_IPK not defined, unable to package")
132                 return
133
134         dvar = bb.data.getVar('D', d, 1)
135         if not dvar:
136                 bb.error("D not defined, unable to package")
137                 return
138         bb.mkdirhier(dvar)
139
140         tmpdir = bb.data.getVar('TMPDIR', d, 1)
141
142         if os.access(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"), os.R_OK):
143                 os.unlink(os.path.join(tmpdir, "stamps", "IPK_PACKAGE_INDEX_CLEAN"))
144
145         packages = bb.data.getVar('PACKAGES', d, True)
146         for pkg in packages.split():
147                 localdata = bb.data.createCopy(d)
148                 pkgdest = bb.data.getVar('PKGDEST', d, 1)
149                 root = "%s/%s" % (pkgdest, pkg)
150
151                 lf = bb.utils.lockfile(root + ".lock")
152
153                 bb.data.setVar('ROOT', '', localdata)
154                 bb.data.setVar('ROOT_%s' % pkg, root, localdata)
155                 pkgname = bb.data.getVar('PKG_%s' % pkg, localdata, 1)
156                 if not pkgname:
157                         pkgname = pkg
158                 bb.data.setVar('PKG', pkgname, localdata)
159
160                 overrides = bb.data.getVar('OVERRIDES', localdata)
161                 if not overrides:
162                         raise bb.build.FuncFailed('OVERRIDES not defined')
163                 overrides = bb.data.expand(overrides, localdata)
164                 bb.data.setVar('OVERRIDES', overrides + ':' + pkg, localdata)
165
166                 bb.data.update_data(localdata)
167                 basedir = os.path.join(os.path.dirname(root))
168                 arch = bb.data.getVar('PACKAGE_ARCH', localdata, 1)
169                 pkgoutdir = "%s/%s" % (outdir, arch)
170                 bb.mkdirhier(pkgoutdir)
171                 os.chdir(root)
172                 from glob import glob
173                 g = glob('*')
174                 try:
175                         del g[g.index('CONTROL')]
176                         del g[g.index('./CONTROL')]
177                 except ValueError:
178                         pass
179                 if not g and bb.data.getVar('ALLOW_EMPTY', localdata) != "1":
180                         from bb import note
181                         note("Not creating empty archive for %s-%s-%s" % (pkg, bb.data.getVar('PV', localdata, 1), bb.data.getVar('PR', localdata, 1)))
182                         bb.utils.unlockfile(lf)
183                         continue
184
185                 controldir = os.path.join(root, 'CONTROL')
186                 bb.mkdirhier(controldir)
187                 try:
188                         ctrlfile = file(os.path.join(controldir, 'control'), 'w')
189                 except OSError:
190                         bb.utils.unlockfile(lf)
191                         raise bb.build.FuncFailed("unable to open control file for writing.")
192
193                 fields = []
194                 pe = bb.data.getVar('PE', d, 1)
195                 if pe and int(pe) > 0:
196                         fields.append(["Version: %s:%s-%s\n", ['PE', 'PV', 'PR']])
197                 else:
198                         fields.append(["Version: %s-%s\n", ['PV', 'PR']])
199                 fields.append(["Description: %s\n", ['DESCRIPTION']])
200                 fields.append(["Section: %s\n", ['SECTION']])
201                 fields.append(["Priority: %s\n", ['PRIORITY']])
202                 fields.append(["Maintainer: %s\n", ['MAINTAINER']])
203                 fields.append(["Architecture: %s\n", ['PACKAGE_ARCH']])
204                 fields.append(["OE: %s\n", ['PN']])
205                 fields.append(["Homepage: %s\n", ['HOMEPAGE']])
206
207                 def pullData(l, d):
208                         l2 = []
209                         for i in l:
210                                 l2.append(bb.data.getVar(i, d, 1))
211                         return l2
212
213                 ctrlfile.write("Package: %s\n" % pkgname)
214                 # check for required fields
215                 try:
216                         for (c, fs) in fields:
217                                 for f in fs:
218                                         if bb.data.getVar(f, localdata) is None:
219                                                 raise KeyError(f)
220                                 ctrlfile.write(c % tuple(pullData(fs, localdata)))
221                 except KeyError:
222                         (type, value, traceback) = sys.exc_info()
223                         ctrlfile.close()
224                         bb.utils.unlockfile(lf)
225                         raise bb.build.FuncFailed("Missing field for ipk generation: %s" % value)
226                 # more fields
227
228                 bb.build.exec_func("mapping_rename_hook", localdata)
229
230                 rdepends = explode_deps(bb.data.getVar("RDEPENDS", localdata, 1) or "")
231                 rrecommends = explode_deps(bb.data.getVar("RRECOMMENDS", localdata, 1) or "")
232                 rsuggests = (bb.data.getVar("RSUGGESTS", localdata, 1) or "").split()
233                 rprovides = (bb.data.getVar("RPROVIDES", localdata, 1) or "").split()
234                 rreplaces = (bb.data.getVar("RREPLACES", localdata, 1) or "").split()
235                 rconflicts = (bb.data.getVar("RCONFLICTS", localdata, 1) or "").split()
236                 if rdepends:
237                         ctrlfile.write("Depends: %s\n" % ", ".join(rdepends))
238                 if rsuggests:
239                         ctrlfile.write("Suggests: %s\n" % ", ".join(rsuggests))
240                 if rrecommends:
241                         ctrlfile.write("Recommends: %s\n" % ", ".join(rrecommends))
242                 if rprovides:
243                         ctrlfile.write("Provides: %s\n" % ", ".join(rprovides))
244                 if rreplaces:
245                         ctrlfile.write("Replaces: %s\n" % ", ".join(rreplaces))
246                 if rconflicts:
247                         ctrlfile.write("Conflicts: %s\n" % ", ".join(rconflicts))
248                 src_uri = bb.data.getVar("SRC_URI", localdata, 1)
249                 if src_uri:
250                         src_uri = re.sub("\s+", " ", src_uri)
251                         ctrlfile.write("Source: %s\n" % " ".join(src_uri.split()))
252                 ctrlfile.close()
253
254                 for script in ["preinst", "postinst", "prerm", "postrm"]:
255                         scriptvar = bb.data.getVar('pkg_%s' % script, localdata, 1)
256                         if not scriptvar:
257                                 continue
258                         try:
259                                 scriptfile = file(os.path.join(controldir, script), 'w')
260                         except OSError:
261                                 bb.utils.unlockfile(lf)
262                                 raise bb.build.FuncFailed("unable to open %s script file for writing." % script)
263                         scriptfile.write(scriptvar)
264                         scriptfile.close()
265                         os.chmod(os.path.join(controldir, script), 0755)
266
267                 conffiles_str = bb.data.getVar("CONFFILES", localdata, 1)
268                 if conffiles_str:
269                         try:
270                                 conffiles = file(os.path.join(controldir, 'conffiles'), 'w')
271                         except OSError:
272                                 bb.utils.unlockfile(lf)
273                                 raise bb.build.FuncFailed("unable to open conffiles for writing.")
274                         for f in conffiles_str.split():
275                                 conffiles.write('%s\n' % f)
276                         conffiles.close()
277
278                 os.chdir(basedir)
279                 ret = os.system("PATH=\"%s\" %s %s %s" % (bb.data.getVar("PATH", localdata, 1), 
280                                                           bb.data.getVar("IPKGBUILDCMD",d,1), pkg, pkgoutdir))
281                 if ret != 0:
282                         bb.utils.unlockfile(lf)
283                         raise bb.build.FuncFailed("ipkg-build execution failed")
284
285                 for script in ["preinst", "postinst", "prerm", "postrm", "control" ]:
286                         scriptfile = os.path.join(controldir, script)
287                         try:
288                                 os.remove(scriptfile)
289                         except OSError:
290                                 pass
291                 try:
292                         os.rmdir(controldir)
293                 except OSError:
294                         pass
295                 bb.utils.unlockfile(lf)
296 }
297
298 python () {
299     import bb
300     if bb.data.getVar('PACKAGES', d, True) != '':
301         deps = (bb.data.getVarFlag('do_package_write_ipk', 'depends', d) or "").split()
302         deps.append('ipkg-utils-native:do_populate_staging')
303         deps.append('fakeroot-native:do_populate_staging')
304         bb.data.setVarFlag('do_package_write_ipk', 'depends', " ".join(deps), d)
305 }
306
307 python do_package_write_ipk () {
308         packages = bb.data.getVar('PACKAGES', d, True)
309         if not packages:
310                 bb.debug(1, "No PACKAGES defined, nothing to package")
311                 return
312
313         bb.build.exec_func("read_subpackage_metadata", d)
314         bb.build.exec_func("do_package_ipk", d)
315 }
316 do_package_write_ipk[dirs] = "${D}"
317 addtask package_write_ipk before do_package_write after do_package