package_(deb|ipk).bbclass: Rename package index stamp to make it more obvious what...
[vuplus_openembedded] / classes / package_deb.bbclass
1 #
2 # Copyright 2006-2007 OpenedHand Ltd.
3 #
4
5 inherit package
6
7 BOOTSTRAP_EXTRA_RDEPENDS += "dpkg"
8 DISTRO_EXTRA_RDEPENDS += "dpkg"
9 IMAGE_PKGTYPE ?= "deb"
10
11 # Map TARGET_ARCH to Debian's ideas about architectures
12 DPKG_ARCH ?= "${TARGET_ARCH}" 
13 DPKG_ARCH_x86 ?= "i386"
14 DPKG_ARCH_i486 ?= "i386"
15 DPKG_ARCH_i586 ?= "i386"
16 DPKG_ARCH_i686 ?= "i386"
17 DPKG_ARCH_pentium ?= "i386"
18
19 python package_deb_fn () {
20     from bb import data
21     bb.data.setVar('PKGFN', bb.data.getVar('PKG',d), d)
22 }
23
24 addtask package_deb_install
25 python do_package_deb_install () {
26     import os, sys
27     pkg = bb.data.getVar('PKG', d, 1)
28     pkgfn = bb.data.getVar('PKGFN', d, 1)
29     rootfs = bb.data.getVar('IMAGE_ROOTFS', d, 1)
30     debdir = bb.data.getVar('DEPLOY_DIR_DEB', d, 1)
31     stagingdir = bb.data.getVar('STAGING_DIR', d, 1)
32     stagingbindir = bb.data.getVar('STAGING_BINDIR_NATIVE', d, 1)
33     tmpdir = bb.data.getVar('TMPDIR', d, 1)
34
35     if None in (pkg,pkgfn,rootfs):
36         raise bb.build.FuncFailed("missing variables (one or more of PKG, PKGFN, IMAGE_ROOTFS)")
37     try:
38         if not os.exists(rootfs):
39             os.makedirs(rootfs)
40         os.chdir(rootfs)
41     except OSError:
42         raise bb.build.FuncFailed(str(sys.exc_value))
43
44     # update packages file
45     (exitstatus, output) = commands.getstatusoutput('dpkg-scanpackages %s > %s/Packages' % (debdir, debdir))
46     if (exitstatus != 0 ):
47         raise bb.build.FuncFailed(output)
48
49     f = open(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN"), "w")
50     f.close()
51
52     # NOTE: this env stuff is racy at best, we need something more capable
53     # than 'commands' for command execution, which includes manipulating the
54     # env of the fork+execve'd processs
55
56     # Set up environment
57     apt_config = os.getenv('APT_CONFIG')
58     os.putenv('APT_CONFIG', os.path.join(stagingdir, 'etc', 'apt', 'apt.conf'))
59     path = os.getenv('PATH')
60     os.putenv('PATH', '%s:%s' % (stagingbindir, os.getenv('PATH')))
61
62     # install package
63     commands.getstatusoutput('apt-get update')
64     commands.getstatusoutput('apt-get install -y %s' % pkgfn)
65
66     # revert environment
67     os.putenv('APT_CONFIG', apt_config)
68     os.putenv('PATH', path)
69 }
70
71 python do_package_deb () {
72     import sys, re, fcntl, copy
73
74     workdir = bb.data.getVar('WORKDIR', d, 1)
75     if not workdir:
76         bb.error("WORKDIR not defined, unable to package")
77         return
78
79     import os # path manipulations
80     outdir = bb.data.getVar('DEPLOY_DIR_DEB', d, 1)
81     if not outdir:
82         bb.error("DEPLOY_DIR_DEB not defined, unable to package")
83         return
84
85     dvar = bb.data.getVar('D', d, 1)
86     if not dvar:
87         bb.error("D not defined, unable to package")
88         return
89     bb.mkdirhier(dvar)
90
91     packages = bb.data.getVar('PACKAGES', d, 1)
92     if not packages:
93         bb.debug(1, "PACKAGES not defined, nothing to package")
94         return
95
96     tmpdir = bb.data.getVar('TMPDIR', d, 1)
97
98     if os.access(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN"),os.R_OK):
99         os.unlink(os.path.join(tmpdir, "stamps", "DEB_PACKAGE_INDEX_CLEAN"))
100
101     if packages == []:
102         bb.debug(1, "No packages; nothing to do")
103         return
104
105     def lockfile(name):
106         lf = open(name, "a+")
107         fcntl.flock(lf.fileno(), fcntl.LOCK_EX)
108         return lf
109
110     def unlockfile(lf):
111         fcntl.flock(lf.fileno(), fcntl.LOCK_UN)
112         lf.close
113
114     for pkg in packages.split():
115         localdata = bb.data.createCopy(d)
116         root = "%s/install/%s" % (workdir, pkg)
117
118         lf = lockfile(root + ".lock")
119
120         bb.data.setVar('ROOT', '', localdata)
121         bb.data.setVar('ROOT_%s' % pkg, root, localdata)
122         pkgname = bb.data.getVar('PKG_%s' % pkg, localdata, 1)
123         if not pkgname:
124             pkgname = pkg
125         bb.data.setVar('PKG', pkgname, localdata)
126
127         overrides = bb.data.getVar('OVERRIDES', localdata)
128         if not overrides:
129             raise bb.build.FuncFailed('OVERRIDES not defined')
130         overrides = bb.data.expand(overrides, localdata)
131         bb.data.setVar('OVERRIDES', overrides + ':' + pkg, localdata)
132
133         bb.data.update_data(localdata)
134         basedir = os.path.join(os.path.dirname(root))
135
136         pkgoutdir = os.path.join(outdir, bb.data.getVar('PACKAGE_ARCH', localdata, 1))
137         bb.mkdirhier(pkgoutdir)
138
139         os.chdir(root)
140         from glob import glob
141         g = glob('*')
142         try:
143             del g[g.index('DEBIAN')]
144             del g[g.index('./DEBIAN')]
145         except ValueError:
146             pass
147         if not g and bb.data.getVar('ALLOW_EMPTY', localdata) != "1":
148             from bb import note
149             note("Not creating empty archive for %s-%s-%s" % (pkg, bb.data.getVar('PV', localdata, 1), bb.data.getVar('PR', localdata, 1)))
150             unlockfile(lf)
151             continue
152
153         controldir = os.path.join(root, 'DEBIAN')
154         bb.mkdirhier(controldir)
155         os.chmod(controldir, 0755)
156         try:
157             ctrlfile = file(os.path.join(controldir, 'control'), 'wb')
158             # import codecs
159             # ctrlfile = codecs.open("someFile", "w", "utf-8")
160         except OSError:
161             raise bb.build.FuncFailed("unable to open control file for writing.")
162
163         fields = []
164         pe = bb.data.getVar('PE', d, 1)
165         if pe and int(pe) > 0:
166             fields.append(["Version: %s:%s-%s\n", ['PE', 'PV', 'PR']])
167         else:
168             fields.append(["Version: %s-%s\n", ['PV', 'PR']])
169         fields.append(["Description: %s\n", ['DESCRIPTION']])
170         fields.append(["Section: %s\n", ['SECTION']])
171         fields.append(["Priority: %s\n", ['PRIORITY']])
172         fields.append(["Maintainer: %s\n", ['MAINTAINER']])
173         fields.append(["Architecture: %s\n", ['DPKG_ARCH']])
174         fields.append(["OE: %s\n", ['PN']])
175         fields.append(["Homepage: %s\n", ['HOMEPAGE']])
176
177 #        Package, Version, Maintainer, Description - mandatory
178 #        Section, Priority, Essential, Architecture, Source, Depends, Pre-Depends, Recommends, Suggests, Conflicts, Replaces, Provides - Optional
179
180
181         def pullData(l, d):
182             l2 = []
183             for i in l:
184                 data = bb.data.getVar(i, d, 1)
185                 if data is None:
186                     raise KeyError(f)
187                 if i == 'DPKG_ARCH' and bb.data.getVar('PACKAGE_ARCH', d, 1) == 'all':
188                     data = 'all'
189                 l2.append(data)
190             return l2
191
192         ctrlfile.write("Package: %s\n" % pkgname)
193         # check for required fields
194         try:
195             for (c, fs) in fields:
196                 ctrlfile.write(unicode(c % tuple(pullData(fs, localdata))))
197         except KeyError:
198             (type, value, traceback) = sys.exc_info()
199             ctrlfile.close()
200             raise bb.build.FuncFailed("Missing field for deb generation: %s" % value)
201         # more fields
202
203         bb.build.exec_func("mapping_rename_hook", localdata)
204
205         rdepends = explode_deps(unicode(bb.data.getVar("RDEPENDS", localdata, 1) or ""))
206         rdepends = [dep for dep in rdepends if not '*' in dep]
207         rrecommends = explode_deps(unicode(bb.data.getVar("RRECOMMENDS", localdata, 1) or ""))
208         rrecommends = [rec for rec in rrecommends if not '*' in rec]
209         rsuggests = (unicode(bb.data.getVar("RSUGGESTS", localdata, 1) or "")).split()
210         rprovides = (unicode(bb.data.getVar("RPROVIDES", localdata, 1) or "")).split()
211         rreplaces = (unicode(bb.data.getVar("RREPLACES", localdata, 1) or "")).split()
212         rconflicts = (unicode(bb.data.getVar("RCONFLICTS", localdata, 1) or "")).split()
213         if rdepends:
214             ctrlfile.write(u"Depends: %s\n" % ", ".join(rdepends))
215         if rsuggests:
216             ctrlfile.write(u"Suggests: %s\n" % ", ".join(rsuggests))
217         if rrecommends:
218             ctrlfile.write(u"Recommends: %s\n" % ", ".join(rrecommends))
219         if rprovides:
220             ctrlfile.write(u"Provides: %s\n" % ", ".join(rprovides))
221         if rreplaces:
222             ctrlfile.write(u"Replaces: %s\n" % ", ".join(rreplaces))
223         if rconflicts:
224             ctrlfile.write(u"Conflicts: %s\n" % ", ".join(rconflicts))
225         ctrlfile.close()
226
227         for script in ["preinst", "postinst", "prerm", "postrm"]:
228             scriptvar = bb.data.getVar('pkg_%s' % script, localdata, 1)
229             if not scriptvar:
230                 continue
231             try:
232                 scriptfile = file(os.path.join(controldir, script), 'w')
233             except OSError:
234                 raise bb.build.FuncFailed("unable to open %s script file for writing." % script)
235             scriptfile.write("#!/bin/sh\n")
236             scriptfile.write(scriptvar)
237             scriptfile.close()
238             os.chmod(os.path.join(controldir, script), 0755)
239
240         conffiles_str = bb.data.getVar("CONFFILES", localdata, 1)
241         if conffiles_str:
242             try:
243                 conffiles = file(os.path.join(controldir, 'conffiles'), 'w')
244             except OSError:
245                 raise bb.build.FuncFailed("unable to open conffiles for writing.")
246             for f in conffiles_str.split():
247                 conffiles.write('%s\n' % f)
248             conffiles.close()
249
250         os.chdir(basedir)
251         ret = os.system("PATH=\"%s\" fakeroot dpkg-deb -b %s %s" % (bb.data.getVar("PATH", localdata, 1), root, pkgoutdir))
252         if ret != 0:
253             raise bb.build.FuncFailed("dpkg-deb execution failed")
254
255         for script in ["preinst", "postinst", "prerm", "postrm", "control" ]:
256             scriptfile = os.path.join(controldir, script)
257             try:
258                 os.remove(scriptfile)
259             except OSError:
260                 pass
261         try:
262             os.rmdir(controldir)
263         except OSError:
264             pass
265
266         unlockfile(lf)
267 }
268
269 python () {
270     import bb
271     if bb.data.getVar('PACKAGES', d, True) != '':
272         bb.data.setVarFlag('do_package_write_deb', 'depends', 'dpkg-native:do_populate_staging fakeroot-native:do_populate_staging', d)
273 }
274
275 python do_package_write_deb () {
276         bb.build.exec_func("read_subpackage_metadata", d)
277         bb.build.exec_func("do_package_deb", d)
278 }
279 do_package_write_deb[dirs] = "${D}"
280 addtask package_write_deb before do_package_write after do_package
281