merge of '276211ed4b7bdea623bfc78d10218ee0c8faf259'
[vuplus_openembedded] / classes / openmoko2.bbclass
1 inherit autotools pkgconfig
2
3 HOMEPAGE = "http://www.openmoko.org"
4 OPENMOKO_RELEASE ?= "OM-2007.2"
5 OPENMOKO_MIRROR ?= "svn://svn.openmoko.org/trunk"
6
7 def openmoko_two_get_license(d):
8     import bb
9     openmoko, section = bb.data.getVar('SECTION', d, 1).split("/")
10     return "LGPL GPL".split()[section != "libs"]
11
12 def openmoko_two_get_subdir(d):
13     import bb
14     openmoko, section = bb.data.getVar('SECTION', d, 1).split("/")
15     if section == 'base': return ""
16     elif section == 'libs': return "libraries"
17     elif section in 'apps tools pim'.split(): return "applications"
18     elif section == "panel-plugin": return "panel-plugins"
19     elif section == "inputmethods": return "inputmethods"
20     elif section == "daemons": return "daemons"
21     elif section == "misc": return "misc"
22     else: return section
23
24 LICENSE = "${@openmoko_two_get_license(d)}"
25 SUBDIR = "${@openmoko_two_get_subdir(d)}"
26
27 SRC_URI := "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/${SUBDIR};module=${PN};proto=http"
28 S = "${WORKDIR}/${PN}"
29
30 FILES_${PN} += "${datadir}/icons"
31
32 SVNREV = "r${SRCREV}"
33 #SVNREV = "${SRCDATE}"