merge of 184b27ced469fdd85ff3130c07f410177622b810
[vuplus_openembedded] / classes / native.bbclass
1 inherit base
2
3 # Native packages are built indirectly via dependency,
4 # no need for them to be a direct target of 'world'
5 EXCLUDE_FROM_WORLD = "1"
6
7 PACKAGES = ""
8 PACKAGE_ARCH = "${BUILD_ARCH}"
9
10 # When this class has packaging enabled, setting 
11 # RPROVIDES becomes unnecessary.
12 RPROVIDES = "${PN}"
13
14 # Need to resolve package RDEPENDS as well as DEPENDS
15 BUILD_ALL_DEPS = "1"
16
17 # Break the circular dependency as a result of DEPENDS
18 # in package.bbclass
19 PACKAGE_DEPENDS = ""
20
21 TARGET_ARCH = "${BUILD_ARCH}"
22 TARGET_OS = "${BUILD_OS}"
23 TARGET_VENDOR = "${BUILD_VENDOR}"
24 TARGET_PREFIX = "${BUILD_PREFIX}"
25 TARGET_CC_ARCH = "${BUILD_CC_ARCH}"
26
27 HOST_ARCH = "${BUILD_ARCH}"
28 HOST_OS = "${BUILD_OS}"
29 HOST_VENDOR = "${BUILD_VENDOR}"
30 HOST_PREFIX = "${BUILD_PREFIX}"
31 HOST_CC_ARCH = "${BUILD_CC_ARCH}"
32
33 CPPFLAGS = "${BUILD_CPPFLAGS}"
34 CFLAGS = "${BUILD_CFLAGS}"
35 CXXFLAGS = "${BUILD_CFLAGS}"
36 LDFLAGS = "${BUILD_LDFLAGS}"
37 LDFLAGS_build-darwin = "-L${STAGING_DIR}/${BUILD_SYS}/lib "
38
39 # Path prefixes
40 base_prefix = "${exec_prefix}"
41 prefix = "${STAGING_DIR}"
42 exec_prefix = "${STAGING_DIR}/${BUILD_ARCH}-${BUILD_OS}"
43
44 # Base paths
45 base_bindir = "${base_prefix}/bin"
46 base_sbindir = "${base_prefix}/bin"
47 base_libdir = "${base_prefix}/lib"
48
49 # Architecture independent paths
50 sysconfdir = "${prefix}/etc"
51 sharedstatedir = "${prefix}/com"
52 localstatedir = "${prefix}/var"
53 infodir = "${datadir}/info"
54 mandir = "${datadir}/man"
55 docdir = "${datadir}/doc"
56 servicedir = "${prefix}/srv"
57
58 # Architecture dependent paths
59 bindir = "${exec_prefix}/bin"
60 sbindir = "${exec_prefix}/bin"
61 libexecdir = "${exec_prefix}/libexec"
62 libdir = "${exec_prefix}/lib"
63 includedir = "${exec_prefix}/include"
64 oldincludedir = "${exec_prefix}/include"
65
66 # Datadir is made arch dependent here, primarily
67 # for autoconf macros, and other things that
68 # may be manipulated to handle crosscompilation
69 # issues.
70 datadir = "${exec_prefix}/share"
71
72 do_stage () {
73         if [ "${INHIBIT_NATIVE_STAGE_INSTALL}" != "1" ]
74         then
75                 oe_runmake install
76         fi
77 }
78
79 do_install () {
80         true
81 }