merge of 94dc534986dc5c018c2c127e01fa7cac5f51270a
[vuplus_openembedded] / classes / native.bbclass
1 inherit base
2
3 # Native packages are built indirectly via dependency,
4 # no need for them to be a direct target of 'world'
5 EXCLUDE_FROM_WORLD = "1"
6
7 PACKAGES = ""
8 PACKAGE_ARCH = "${BUILD_ARCH}"
9
10 # When this class has packaging enabled, setting 
11 # RPROVIDES becomes unnecessary.
12 RPROVIDES = "${PN}"
13
14 # Need to resolve package RDEPENDS as well as DEPENDS
15 BUILD_ALL_DEPS = "1"
16
17 TARGET_ARCH = "${BUILD_ARCH}"
18 TARGET_OS = "${BUILD_OS}"
19 TARGET_VENDOR = "${BUILD_VENDOR}"
20 TARGET_PREFIX = "${BUILD_PREFIX}"
21 TARGET_CC_ARCH = "${BUILD_CC_ARCH}"
22
23 HOST_ARCH = "${BUILD_ARCH}"
24 HOST_OS = "${BUILD_OS}"
25 HOST_VENDOR = "${BUILD_VENDOR}"
26 HOST_PREFIX = "${BUILD_PREFIX}"
27 HOST_CC_ARCH = "${BUILD_CC_ARCH}"
28
29 CPPFLAGS = "${BUILD_CPPFLAGS}"
30 CFLAGS = "${BUILD_CFLAGS}"
31 CXXFLAGS = "${BUILD_CFLAGS}"
32 LDFLAGS = "${BUILD_LDFLAGS}"
33
34 # Path prefixes
35 base_prefix = "${exec_prefix}"
36 prefix = "${STAGING_DIR}"
37 exec_prefix = "${STAGING_DIR}/${BUILD_ARCH}-${BUILD_OS}"
38
39 # Base paths
40 base_bindir = "${base_prefix}/bin"
41 base_sbindir = "${base_prefix}/bin"
42 base_libdir = "${base_prefix}/lib"
43
44 # Architecture independent paths
45 sysconfdir = "${prefix}/etc"
46 sharedstatedir = "${prefix}/com"
47 localstatedir = "${prefix}/var"
48 infodir = "${datadir}/info"
49 mandir = "${datadir}/man"
50 docdir = "${datadir}/doc"
51 servicedir = "${prefix}/srv"
52
53 # Architecture dependent paths
54 bindir = "${exec_prefix}/bin"
55 sbindir = "${exec_prefix}/bin"
56 libexecdir = "${exec_prefix}/libexec"
57 libdir = "${exec_prefix}/lib"
58 includedir = "${exec_prefix}/include"
59 oldincludedir = "${exec_prefix}/include"
60
61 # Datadir is made arch dependent here, primarily
62 # for autoconf macros, and other things that
63 # may be manipulated to handle crosscompilation
64 # issues.
65 datadir = "${exec_prefix}/share"
66
67 do_stage () {
68         if [ "${INHIBIT_NATIVE_STAGE_INSTALL}" != "1" ]
69         then
70                 oe_runmake install
71         fi
72 }
73
74 do_install () {
75         true
76 }