merge of '49118a4c6035353c0f8cf1aa30297dd36e43241f'
[vuplus_openembedded] / classes / java.bbclass
1 # Defines the commonly used target directories and provides a convenience
2 # function to install jar files.
3 #
4 # All the default directory locations herein resemble locations chosen in
5 # the Debian distribution.
6
7 # Jar location on target
8 datadir_java ?= ${datadir}/java
9
10 # JNI library location on target
11 libdir_jni ?= ${libdir}/jni
12
13 # JVM bundle location on target
14 libdir_jvm ?= ${libdir}/jvm
15
16 STAGING_DATADIR_JAVA ?= ${STAGING_DATADIR}/java
17 STAGING_LIBDIR_JNI ?= ${STAGING_LIBDIR}/jni
18 STAGING_LIBDIR_JVM ?= ${STAGING_LIBDIR}/jvm
19
20 oe_jarinstall() {
21   # Purpose: Install a jar file and create all the given symlinks to it.
22   # Example:
23   # oe_jarinstall foo-1.3.jar foo.jar
24   # Installs foo-1.3.jar and creates symlink foo.jar.
25   #
26   # oe_jarinstall -s foo-1.3.jar foo.jar
27   # Installs foo-1.3.jar to staging and creates symlink foo.jar.
28   #
29   # oe_jarinstall -r foo-1.3.jar foo_1_3.jar foo.jar
30   # Installs foo_1_3.jar as foo-1.3.jar and creates a symlink to this.
31   #
32   dir=${D}${datadir_java}
33   destname=""
34   while [ "$#" -gt 0 ]; do
35     case "$1" in
36     -s)
37       dir=${STAGING_DATADIR_JAVA}
38       ;;
39     -r)
40       shift
41       destname=$1
42       ;;
43     -*)
44       oefatal "oe_jarinstall: unknown option: $1"
45       ;;
46     *)
47       break;
48       ;;
49     esac
50     shift
51   done
52
53   jarname=$1
54   destname=${destname:-`basename $jarname`}
55   shift
56
57   install -d $dir
58   install -m 0644 $jarname $dir/$destname
59
60   # Creates symlinks out of the remaining arguments.
61   while [ "$#" -gt 0 ]; do
62     if [ -e $dir/$1 ]; then
63       oewarn "file was in the way. removing:" $dir/$1
64       rm $dir/$1
65     fi
66     ln -s $destname $dir/$1
67     shift
68   done
69 }
70
71 oe_makeclasspath() {
72   # Purpose: Generate a classpath variable from the given Jar file names
73   # where the ".jar" has been omitted.
74   #
75   # oe_makeclasspath foo baz bar
76   # Prints ${datadir_java}/foo.jar:${datadir_java}/baz.jar:${datadir_java}/bar.jar
77   #
78   # oe_makeclasspath -s foo baz bar
79   # Prints ${STAGING_DATADIR_JAVA}/foo.jar:${STAGING_DATADIR_JAVA}/baz.jar:${STAGING_DATADIR_JAVA}/bar.jar
80   #
81   # Provide the -s at the beginning otherwise strange things happen.
82   #
83   dir=${datadir_java}
84         classpath=
85         delimiter=
86
87   while [ "$#" -gt 0 ]; do
88     case "$1" in
89     -s)
90       dir=${STAGING_DATADIR_JAVA}
91       ;;
92     -*)
93       oefatal "oe_makeclasspath: unknown option: $1"
94       ;;
95     *)
96       classpath=$classpath$delimiter$dir/$1.jar
97       delimiter=":"
98       ;;
99     esac
100     shift
101   done
102
103         echo $classpath
104 }
105
106 # Creates a simple wrapper script for your Java program.
107 # The script is written to ${PN} by default. 
108 #
109 # Parameters are as follows:
110 # [options] <output file> <main class> [jar files ...]
111 #
112 # Options are
113 # -o <name> where name is the output file name
114 #
115 # It can only take jar files from ${datadir_java}!
116 oe_java_simple_wrapper() {
117   delimiter=
118   mainclass=
119   classpath=
120   output=${PN}
121
122   while [ "$#" -gt 0 ]; do
123     case "$1" in
124     -o)
125       shift
126       output=$1
127       ;;
128     -*)
129       oefatal "oe_java_simple_wrapper: unknown option: $1"
130       ;;
131     *)
132       if [ $mainclass ]
133       then
134         classpath=$classpath$delimiter${datadir_java}/$1
135         delimiter=":"
136       else
137         mainclass=$1
138       fi
139       ;;
140     esac
141     shift
142   done
143
144   oenote "Creating simple Java wrapper script"
145   oenote "Output File: $output"
146   oenote "Main Class: $mainclass"
147   oenote "Classpath: $classpath"
148
149   echo "#!/bin/sh" > $output
150   echo "# This file is autogenerated by the oe_java_simple_wrapper function of OpenEmbedded" >> $output
151   echo >> $output
152   echo "# You can provide additional VM arguments by setting the VMARGS environment variable." >> $output
153   echo "CLASSPATH_ARG=\"-cp $classpath\"" >> $output
154   echo >> $output
155   echo "MAIN_CLASS=$mainclass" >> $output
156   echo >> $output
157   echo "# Allows overriding the VM by setting the JAVA environment variable." >> $output
158   echo "if [ x\${JAVA} = x ]" >> $output
159   echo "then" >> $output
160   echo "  JAVA=java" >> $output
161   echo "fi" >> $output
162   echo >> $output
163   echo "exec \${JAVA} \${VMARGS} \${CLASSPATH_ARG} \${MAIN_CLASS} \${@}" >> $output
164 }