propagate from branch 'org.openembedded.dev' (head 2c4036a31ef41e89a3bef730def510b4cf...
[vuplus_openembedded] / classes / gpe.bbclass
1 DEPENDS_prepend = "coreutils-native virtual/libintl intltool-native "
2 GPE_SRC_COMPRESSION ?= "gz"
3 SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.${GPE_SRC_COMPRESSION}"
4 FILES_${PN} += "${datadir}/gpe ${datadir}/application-registry"
5
6 inherit gettext
7
8 gpe_do_compile() {
9         oe_runmake PREFIX=${prefix}
10 }
11
12 gpe_do_install() {
13         oe_runmake PREFIX=${prefix} DESTDIR=${D} install
14 }
15
16 EXPORT_FUNCTIONS do_compile do_install