merge of '0bb5f3998d4f44cc03385e6faf36b48a3e409038'
[vuplus_openembedded] / classes / distutils.bbclass
1 inherit distutils-base
2
3 distutils_do_compile() {
4         BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
5         ${STAGING_BINDIR_NATIVE}/python setup.py build || \
6         oefatal "python setup.py build execution failed."
7 }
8
9 distutils_do_install() {
10         BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
11         ${STAGING_BINDIR_NATIVE}/python setup.py install --prefix=${D}/${prefix} --install-data=${D}/${datadir} || \
12         oefatal "python setup.py install execution failed."
13 }
14
15 EXPORT_FUNCTIONS do_compile do_install