merge of 'd3c8a06d1d4f7abaf8f97964d82c9c0811415c68'
[vuplus_openembedded] / classes / distutils-base.bbclass
1 EXTRA_OEMAKE = ""
2 DEPENDS  += "${@["python-native python", ""][(bb.data.getVar('PACKAGES', d, 1) == '')]}"
3 RDEPENDS += "python-core"
4
5 export STAGING_INCDIR
6 export STAGING_LIBDIR
7
8 def python_dir(d):
9         import os, bb
10         staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
11         if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
12         if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
13         if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
14         raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
15
16 PYTHON_DIR = "${@python_dir(d)}"
17
18 PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc ${PN}"
19
20 FILES_${PN} = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*"
21
22 FILES_${PN}-dev += "\
23   ${libdir}/pkgconfig \
24   ${libdir}/${PYTHON_DIR}/site-packages/*.la \
25 "
26 FILES_${PN}-dbg = "\
27   ${libdir}/${PYTHON_DIR}/site-packages/.debug \
28   ${libdir}/${PYTHON_DIR}/site-packages/*/.debug \
29   ${libdir}/${PYTHON_DIR}/site-packages/*/*/.debug \
30 "