merge of '452ba8f483cc1f311d5139e2d406dd21e8edcce5'
[vuplus_openembedded] / classes / distutils-base.bbclass
1 EXTRA_OEMAKE = ""
2 DEPENDS  += "${@["python-native python", ""][(bb.data.getVar('PACKAGES', d, 1) == '')]}"
3 RDEPENDS += "python-core"
4
5 def python_dir(d):
6         import os, bb
7         staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
8         if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
9         if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
10         if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
11         raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
12
13 PYTHON_DIR = "${@python_dir(d)}"
14
15 PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc ${PN}"
16
17 FILES_${PN} = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*"
18
19 FILES_${PN}-dev += "\
20   ${libdir}/pkgconfig \
21   ${libdir}/${PYTHON_DIR}/site-packages/*.la \
22 "
23 FILES_${PN}-dbg = "\
24   ${libdir}/${PYTHON_DIR}/site-packages/.debug \
25   ${libdir}/${PYTHON_DIR}/site-packages/*/.debug \
26   ${libdir}/${PYTHON_DIR}/site-packages/*/*/.debug \
27 "