merge of '4174da17cc76d0fa9a74373c4588dcabac058e35'
[vuplus_openembedded] / classes / distutils-base.bbclass
1 EXTRA_OEMAKE = ""
2 DEPENDS  += "${@["python-native python", ""][(bb.data.getVar('PACKAGES', d, 1) == '')]}"
3 RDEPENDS += "python-core"
4
5 def python_dir(d):
6         import os, bb
7         staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
8         if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
9         if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
10         if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
11         raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
12
13 PYTHON_DIR = "${@python_dir(d)}"
14 FILES_${PN} = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*"
15 FILES_${PN}-dbg = "${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/.debug \
16                    ${libdir}/${PYTHON_DIR}/site-packages/.debug"
17