merge of '9a82479a1b0af8251aa5c6ea7914cc89f3029f71'
[vuplus_openembedded] / classes / distutils-base.bbclass
1 EXTRA_OEMAKE = ""
2 DEPENDS  += "${@["python-native python", ""][(bb.data.getVar('PACKAGES', d, 1) == '')]}"
3 RDEPENDS += "python-core"
4
5 def python_dir(d):
6         import os, bb
7         staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
8         if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
9         if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
10         raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
11
12 PYTHON_DIR = "${@python_dir(d)}"
13 FILES_${PN} = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}"
14