Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / classes / dietlibc.bbclass
1 DEPENDS =+ "dietlibc"
2
3 def dietlibc_after_parse(d):
4     import bb
5     # Remove the NLS
6     cfg = oe_filter_out('--(dis|en)able-nls', bb.data.getVar('EXTRA_OECONF', d, 1) or "", d)
7     # Remove shared and static and set it right
8     cfg += " --disable-nls --disbale-shared --enable-static"
9     bb.data.setVar('EXTRA_OECONF', cfg, d)
10     cfg = bb.data.getVar('EXTRA_OEMAKE', d, 1) or ""
11     cfg = oe_filter_out("\'CC=", bb.data.getVar('EXTRA_OEMAKE', d, 1) or "", d)
12     cfgtmp = "\'CC=diet ${CCACHE}"
13     cfgtmp += cfg
14     bb.data.setVar('EXTRA_OEMAKE', cfgtmp, d)
15
16 python () {
17     dietlibc_after_parse(d)
18 }
19
20 set_dietlibc_env () {
21         export CC="diet ${CC}"
22 }
23
24 do_compile_prepend() {
25     set_dietlibc_env
26 }
27
28 do_configure_prepend() {
29     set_dietlibc_env
30 }