merge of '1d39316900e922826574e74f55a807cf58b313f7'
[vuplus_openembedded] / classes / cross.bbclass
1 # Cross packages are built indirectly via dependency,
2 # no need for them to be a direct target of 'world'
3 EXCLUDE_FROM_WORLD = "1"
4
5 # Save PACKAGE_ARCH before changing HOST_ARCH
6 OLD_PACKAGE_ARCH := ${PACKAGE_ARCH}
7 PACKAGE_ARCH = ${OLD_PACKAGE_ARCH}
8
9 PACKAGES = ""
10
11 HOST_ARCH = "${BUILD_ARCH}"
12 HOST_VENDOR = "${BUILD_VENDOR}"
13 HOST_OS = "${BUILD_OS}"
14 HOST_PREFIX = "${BUILD_PREFIX}"
15 HOST_CC_ARCH = "${BUILD_CC_ARCH}"
16
17 CPPFLAGS = "${BUILD_CPPFLAGS}"
18 CFLAGS = "${BUILD_CFLAGS}"
19 CXXFLAGS = "${BUILD_CFLAGS}"
20 LDFLAGS = "${BUILD_LDFLAGS}"
21 LDFLAGS_build-darwin = "-L${STAGING_LIBDIR_NATIVE}"
22
23 TOOLCHAIN_OPTIONS = ""
24
25 # Overrides for paths
26
27 # Path prefixes
28 base_prefix = "${exec_prefix}"
29 prefix = "${CROSS_DIR}"
30 exec_prefix = "${prefix}"
31
32 # Base paths
33 base_bindir = "${base_prefix}/bin"
34 base_sbindir = "${base_prefix}/bin"
35 base_libdir = "${base_prefix}/lib"
36
37 # Architecture independent paths
38 datadir = "${prefix}/share"
39 sysconfdir = "${prefix}/etc"
40 sharedstatedir = "${prefix}/com"
41 localstatedir = "${prefix}/var"
42 infodir = "${datadir}/info"
43 mandir = "${datadir}/man"
44 docdir = "${datadir}/doc"
45 servicedir = "${prefix}/srv"
46
47 # Architecture dependent paths
48 bindir = "${exec_prefix}/bin"
49 sbindir = "${exec_prefix}/bin"
50 libexecdir = "${exec_prefix}/libexec"
51 libdir = "${exec_prefix}/lib"
52 includedir = "${exec_prefix}/include"
53 oldincludedir = "${exec_prefix}/include"
54
55 do_stage () {
56         oe_runmake install
57 }
58
59 do_install () {
60         :
61 }