merge of '1eca501d99b909ff783490fdac2b315cd05f4315'
[vuplus_openembedded] / classes / cross.bbclass
1 # Cross packages are built indirectly via dependency,
2 # no need for them to be a direct target of 'world'
3 EXCLUDE_FROM_WORLD = "1"
4
5 # Save PACKAGE_ARCH before changing HOST_ARCH
6 OLD_PACKAGE_ARCH := ${PACKAGE_ARCH}
7 PACKAGE_ARCH = ${OLD_PACKAGE_ARCH}
8
9 PACKAGES = ""
10
11 HOST_ARCH = "${BUILD_ARCH}"
12 HOST_VENDOR = "${BUILD_VENDOR}"
13 HOST_OS = "${BUILD_OS}"
14 HOST_PREFIX = "${BUILD_PREFIX}"
15 HOST_CC_ARCH = "${BUILD_CC_ARCH}"
16
17 CPPFLAGS = "${BUILD_CPPFLAGS}"
18 CFLAGS = "${BUILD_CFLAGS}"
19 CXXFLAGS = "${BUILD_CFLAGS}"
20 LDFLAGS = "${BUILD_LDFLAGS}"
21 LDFLAGS_build-darwin = "-L${STAGING_LIBDIR_NATIVE} "
22
23 # Overrides for paths
24
25 # Path prefixes
26 base_prefix = "${exec_prefix}"
27 prefix = "${CROSS_DIR}"
28 exec_prefix = "${prefix}"
29
30 # Base paths
31 base_bindir = "${base_prefix}/bin"
32 base_sbindir = "${base_prefix}/bin"
33 base_libdir = "${base_prefix}/lib"
34
35 # Architecture independent paths
36 datadir = "${prefix}/share"
37 sysconfdir = "${prefix}/etc"
38 sharedstatedir = "${prefix}/com"
39 localstatedir = "${prefix}/var"
40 infodir = "${datadir}/info"
41 mandir = "${datadir}/man"
42 docdir = "${datadir}/doc"
43 servicedir = "${prefix}/srv"
44
45 # Architecture dependent paths
46 bindir = "${exec_prefix}/bin"
47 sbindir = "${exec_prefix}/bin"
48 libexecdir = "${exec_prefix}/libexec"
49 libdir = "${exec_prefix}/lib"
50 includedir = "${exec_prefix}/include"
51 oldincludedir = "${exec_prefix}/include"
52
53 do_stage () {
54         oe_runmake install
55 }
56
57 do_install () {
58         :
59 }