merge of '7a4784a76121e6cf9b4204ebe5c812e2e540767f'
[vuplus_openembedded] / classes / cmake.bbclass
1 DEPENDS += " cmake-native "
2
3 # We want the staging and installing functions from autotools
4 inherit autotools
5
6 cmake_do_configure() {
7      cmake . -DCMAKE_INSTALL_PREFIX:PATH=${prefix} -Wno-dev \
8      -DCMAKE_FIND_ROOT_PATH=${STAGING_DIR_HOST} \
9      ${EXTRA_OECMAKE}
10 }
11
12 EXPORT_FUNCTIONS do_configure