Add a couple new sed statements to binconfig.bbclass. The current ones weren't fixin...
[vuplus_openembedded] / classes / binconfig.bbclass
1 inherit base
2
3 # The namespaces can clash here hence the two step replace
4 def get_binconfig_mangle(d):
5         import bb.data
6         s = "-e ''"
7         if not bb.data.inherits_class('native', d):
8                 s += " -e 's:=${libdir}:=OELIBDIR:;'"
9                 s += " -e 's:=${includedir}:=OEINCDIR:;'"
10                 s += " -e 's:=${datadir}:=OEDATADIR:'"
11                 s += " -e 's:=${prefix}:=OEPREFIX:'"
12                 s += " -e 's:=${exec_prefix}:=OEEXECPREFIX:'"
13                 s += " -e 's:-L${libdir}:-LOELIBDIR:;'"
14                 s += " -e 's:-I${includedir}:-IOEINCDIR:;'"
15                 s += " -e 's:OELIBDIR:${STAGING_LIBDIR}:;'"
16                 s += " -e 's:OEINCDIR:${STAGING_INCDIR}:;'"
17                 s += " -e 's:OEDATADIR:${STAGING_DATADIR}:'"
18                 s += " -e 's:OEPREFIX:${STAGING_LIBDIR}/..:'"
19                 s += " -e 's:OEEXECPREFIX:${STAGING_LIBDIR}/..:'"
20         return s
21
22 do_stage_append() {
23         for config in `find ${S} -name '*-config'`; do
24                 configname=`basename $config`
25                 install -d ${STAGING_BINDIR}/${HOST_SYS}
26                 cat $config | sed ${@get_binconfig_mangle(d)} > ${STAGING_BINDIR}/${HOST_SYS}/$configname
27                 chmod u+x ${STAGING_BINDIR}/${HOST_SYS}/$configname
28         done
29 }