summaryrefslogtreecommitdiff
path: root/meta-bsp/recipes-vuplus/vuplus-bluetooth-util
diff options
context:
space:
mode:
Diffstat (limited to 'meta-bsp/recipes-vuplus/vuplus-bluetooth-util')
-rw-r--r--meta-bsp/recipes-vuplus/vuplus-bluetooth-util/vuplus-bluetooth-util-vuduo4k.bb10
-rw-r--r--meta-bsp/recipes-vuplus/vuplus-bluetooth-util/vuplus-bluetooth-util.inc6
2 files changed, 14 insertions, 2 deletions
diff --git a/meta-bsp/recipes-vuplus/vuplus-bluetooth-util/vuplus-bluetooth-util-vuduo4k.bb b/meta-bsp/recipes-vuplus/vuplus-bluetooth-util/vuplus-bluetooth-util-vuduo4k.bb
new file mode 100644
index 0000000..13411ee
--- /dev/null
+++ b/meta-bsp/recipes-vuplus/vuplus-bluetooth-util/vuplus-bluetooth-util-vuduo4k.bb
@@ -0,0 +1,10 @@
+require vuplus-bluetooth-util.inc
+
+COMPATIBLE_MACHINE = "^(vuduo4k)$"
+
+SRCDATE = "20181109"
+SRCDATE_PR = "r1"
+
+SRC_URI[md5sum] = "fbbe1050ab72d8ae1b541293eb83a9d6"
+SRC_URI[sha256sum] = "c99de55349d9d8259639a70154956583aa29e1d28517de883d8811934d8bd6b8"
+
diff --git a/meta-bsp/recipes-vuplus/vuplus-bluetooth-util/vuplus-bluetooth-util.inc b/meta-bsp/recipes-vuplus/vuplus-bluetooth-util/vuplus-bluetooth-util.inc
index 65ef794..2845038 100644
--- a/meta-bsp/recipes-vuplus/vuplus-bluetooth-util/vuplus-bluetooth-util.inc
+++ b/meta-bsp/recipes-vuplus/vuplus-bluetooth-util/vuplus-bluetooth-util.inc
@@ -32,8 +32,10 @@ do_install() {
install -m 0644 ${S}/btusb.ko ${D}/usr/local/modules/btusb.ko
install -m 0644 ${S}/bthid.ko ${D}/usr/local/modules/bthid.ko
- install -d ${D}/lib/firmware/${FIRMWARE_PATH}
- install -m 0644 ${S}/${FIRMWARE_FILE} ${D}/lib/firmware/${FIRMWARE_PATH}
+ if [ -n "${FIRMWARE_FILE}" ]; then
+ install -d ${D}/lib/firmware/${FIRMWARE_PATH}
+ install -m 0644 ${S}/${FIRMWARE_FILE} ${D}/lib/firmware/${FIRMWARE_PATH}
+ fi
}
INSANE_SKIP_${PN} = "already-stripped"