summaryrefslogtreecommitdiff
path: root/meta-openvuplus
diff options
context:
space:
mode:
authorhschang <chang@dev3>2017-11-15 07:15:32 (GMT)
committerhschang <chang@dev3>2017-11-15 07:15:32 (GMT)
commit481c21b89cc8ad494cfa6d146d858fb28ae0f461 (patch)
tree6b7a6a50d9a478411a82580ae100db51b7cbeb5a /meta-openvuplus
parent182e48a6426dc4de563695a16f49c3ee5ccc4c04 (diff)
[openwebif] Fix box and remote display.
Diffstat (limited to 'meta-openvuplus')
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb28
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/box_solo4k.pngbin0 -> 12313 bytes
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/box_ultimo4k.pngbin0 -> 7696 bytes
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/box_uno4k.pngbin0 -> 11229 bytes
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/box_uno4kse.pngbin0 -> 39913 bytes
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch81
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/rc_brown.pngbin0 -> 86119 bytes
7 files changed, 103 insertions, 6 deletions
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
index 82784f1..f3d3eb7 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
@@ -12,12 +12,20 @@ SRCREV_pn-${PN}="d84307958746e6a597b43defe5bd1cb78fd745c8"
inherit gitpkgv
PV = "1+git${SRCPV}"
PKGV = "1+git${GITPKGV}"
-PR = "r5"
+PR = "r6"
require openplugins-distutils.inc
-SRC_URI += " file://openwebif_support_vumodels.patch"
-SRC_URI += " file://openwebif_block_in_qpip.patch"
+SRC_URI = "git://github.com/E2OpenPlugins/e2openplugin-${MODULE}.git;protocol=git \
+ file://openwebif_support_vumodels.patch \
+ file://openwebif_block_in_qpip.patch \
+ file://openwebif_vu_box_remote.patch \
+ file://rc_brown.png \
+ file://box_solo4k.png \
+ file://box_uno4k.png \
+ file://box_ultimo4k.png \
+ file://box_uno4kse.png \
+"
# Just a quick hack to "compile" it
do_compile() {
@@ -29,6 +37,11 @@ PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
do_install_append() {
install -d ${D}${PLUGINPATH}
cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
+ install -m 0755 ${WORKDIR}/rc_brown.png ${D}${PLUGINPATH}/public/images/remotes/vu_brown.png
+ install -m 0755 ${WORKDIR}/box_solo4k.png ${D}${PLUGINPATH}/public/images/boxes/solo4k.png
+ install -m 0755 ${WORKDIR}/box_uno4k.png ${D}${PLUGINPATH}/public/images/boxes/uno4k.png
+ install -m 0755 ${WORKDIR}/box_ultimo4k.png ${D}${PLUGINPATH}/public/images/boxes/ultimo4k.png
+ install -m 0755 ${WORKDIR}/box_uno4kse.png ${D}${PLUGINPATH}/public/images/boxes/uno4kse.png
}
python do_package_prepend () {
@@ -41,9 +54,10 @@ python do_package_prepend () {
('vuzero', 'zero.jpg', 'vu_normal.png'),
('vuultimo', 'ultimo.jpg', 'vu_ultimo.png'),
('vuuno', 'uno.jpg', 'vu_normal.png'),
- ('vuultimo4k', 'unknown.jpg', 'vu_normal.png'),
- ('vuuno4k', 'unknown.jpg', 'vu_normal.png'),
- ('vuuno4kse', 'unknown.jpg', 'vu_normal.png'),
+ ('vusolo4k', 'solo4k.png', 'vu_normal.png'),
+ ('vuuno4k', 'uno4k.png', 'vu_normal.png'),
+ ('vuultimo4k', 'ultimo4k.png', 'vu_normal.png'),
+ ('vuuno4kse', 'uno4kse.png', 'vu_brown.png'),
]
import os
top = '${D}${PLUGINPATH}/public/images/'
@@ -68,3 +82,5 @@ FILES_${PN} = "${PLUGINPATH}"
do_populate_sysroot[noexec] = "1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_solo4k.png b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_solo4k.png
new file mode 100644
index 0000000..3a25533
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_solo4k.png
Binary files differ
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_ultimo4k.png b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_ultimo4k.png
new file mode 100644
index 0000000..4a62bed
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_ultimo4k.png
Binary files differ
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_uno4k.png b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_uno4k.png
new file mode 100644
index 0000000..9dc59d0
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_uno4k.png
Binary files differ
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_uno4kse.png b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_uno4kse.png
new file mode 100644
index 0000000..0e54f76
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_uno4kse.png
Binary files differ
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch
new file mode 100644
index 0000000..270d8d5
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch
@@ -0,0 +1,81 @@
+diff --git a/plugin/controllers/ajax.py b/plugin/controllers/ajax.py
+index 9add982..da2be4a 100644
+--- a/plugin/controllers/ajax.py
++++ b/plugin/controllers/ajax.py
+@@ -92,7 +92,9 @@ class AjaxController(BaseController):
+ info = getInfo()
+ type = getBoxType()
+
+- if fileExists(getPublicPath("/images/boxes/"+type+".jpg")):
++ if fileExists(getPublicPath("/images/boxes/"+type+".png")):
++ info["boximage"] = type+".png"
++ elif fileExists(getPublicPath("/images/boxes/"+type+".jpg")):
+ info["boximage"] = type+".jpg"
+ else:
+ info["boximage"] = "unknown.jpg"
+diff --git a/plugin/controllers/models/owibranding.py b/plugin/controllers/models/owibranding.py
+index 9b8f1e5..835cee5 100644
+--- a/plugin/controllers/models/owibranding.py
++++ b/plugin/controllers/models/owibranding.py
+@@ -277,6 +277,8 @@ def getAllInfo():
+ remote = "vu_duo2"
+ elif procmodel == "ultimo":
+ remote = "vu_ultimo"
++ elif procmodel == "uno4kse":
++ remote = "vu_brown"
+ elif procmodel == "e3hd":
+ remote = "e3hd"
+ elif procmodel in ("et9x00", "et9000", "et9200", "et9500"):
+diff --git a/plugin/public/static/remotes/vu_brown.html b/plugin/public/static/remotes/vu_brown.html
+new file mode 100644
+index 0000000..b7835d3
+--- /dev/null
++++ b/plugin/public/static/remotes/vu_brown.html
+@@ -0,0 +1,47 @@
++<img border='0' src='images/remotes/vu_brown.png' usemap='#map' >
++<map name="map">
++ <area shape="circle" coords="71,276,15" id="113" alt="mute" onclick="pressMenuRemote('113');">
++ <area shape="circle" coords="110,26,15" id ="116" alt="Power" onclick="pressMenuRemote('116');">
++ <area shape="circle" coords="31,45,15" id ="388" alt="text" onclick="pressMenuRemote('388');">
++ <area shape="circle" coords="56,45,15" id ="370" alt="subtitle" onclick="pressMenuRemote('370');">
++ <area shape="circle" coords="36,65,15" id ="2" alt="1" onclick="pressMenuRemote('2');">
++ <area shape="circle" coords="68,65,15" id ="3" alt="2" onclick="pressMenuRemote('3');">
++ <area shape="circle" coords="103,65,15" id ="4" alt="3" onclick="pressMenuRemote('4');">
++ <area shape="circle" coords="36,87,15" id ="5" alt="4" onclick="pressMenuRemote('5');">
++ <area shape="circle" coords="68,87,15" id ="6" alt="5" onclick="pressMenuRemote('6');">
++ <area shape="circle" coords="103,87,15" id ="7" alt="6" onclick="pressMenuRemote('7');">
++ <area shape="circle" coords="36,106,15" id ="8" alt="7" onclick="pressMenuRemote('8');">
++ <area shape="circle" coords="68,106,15" id ="9" alt="8" onclick="pressMenuRemote('9');">
++ <area shape="circle" coords="103,106,15" id ="10" alt="9" onclick="pressMenuRemote('10');">
++ <area shape="circle" coords="69,129,15" id ="11" alt="0" onclick="pressMenuRemote('11');">
++ <area shape="circle" coords="36,131,15" id ="412" alt="previous" onclick="pressMenuRemote('412');">
++ <area shape="circle" coords="103,131,15" id ="407" alt="next" onclick="pressMenuRemote('407');">
++ <area shape="circle" coords="32,149,15" id ="398" alt="red" onclick="pressMenuRemote('398');">
++ <area shape="circle" coords="56,149,15" id ="399" alt="green" onclick="pressMenuRemote('399');">
++ <area shape="circle" coords="83,149,15" id ="400" alt="yellow" onclick="pressMenuRemote('400');">
++ <area shape="circle" coords="107,149,15" id ="401" alt="blue" onclick="pressMenuRemote('401');">
++ <area shape="circle" coords="69,177,15" id ="103" alt="up" onclick="pressMenuRemote('103');">
++ <area shape="circle" coords="69,226,15" id ="108" alt="down" onclick="pressMenuRemote('108');">
++ <area shape="circle" coords="45,201,15" id ="105" alt="left" onclick="pressMenuRemote('105');">
++ <area shape="circle" coords="95,201,15" id ="106" alt="right" onclick="pressMenuRemote('106');">
++ <area shape="circle" coords="69,201,20" id ="352" alt="OK" onclick="pressMenuRemote('352');">
++ <area shape="circle" coords="37,260,15" id ="115" alt="volume up" onclick="pressMenuRemote('115');">
++ <area shape="circle" coords="37,291,13" id ="114" alt="volume down" onclick="pressMenuRemote('114');">
++ <area shape="circle" coords="106,234,15" id ="174" alt="exit" onclick="pressMenuRemote('174');">
++ <area shape="circle" coords="33,234,15" id ="358" alt="epg" onclick="pressMenuRemote('358');">
++ <area shape="circle" coords="105,258,15" id ="402" alt="channelup" onclick="pressMenuRemote('402');">
++ <area shape="circle" coords="105,292,15" id ="403" alt="channeldown" onclick="pressMenuRemote('403');">
++ <area shape="circle" coords="105,170,15" id ="139" alt="menu" onclick="pressMenuRemote('139');">
++ <area shape="circle" coords="33,170,15" id ="393" alt="videoaltlast" onclick="pressMenuRemote('393');">
++ <area shape="circle" coords="68,260,15" id ="392" alt="audio" onclick="pressMenuRemote('392');">
++ <area shape="circle" coords="68,292,15" id ="176" alt="timer" onclick="pressMenuRemote('176');">
++ <area shape="circle" coords="110,46,15" id ="138" alt="help" onclick="pressMenuRemote('138');">
++ <area shape="circle" coords="33,314,15" id ="168" alt="rewind" onclick="pressMenuRemote('168');">
++ <area shape="circle" coords="58,314,15" id ="207" alt="play" onclick="pressMenuRemote('207');">
++ <area shape="circle" coords="82,314,15" id ="164" alt="pause" onclick="pressMenuRemote('164');">
++ <area shape="circle" coords="107,314,15" id ="208" alt="forward" onclick="pressMenuRemote('208');">
++ <area shape="circle" coords="34,334,15" id ="377" alt="tv" onclick="pressMenuRemote('377');">
++ <area shape="circle" coords="57,334,15" id ="167" alt="record" onclick="pressMenuRemote('167');">
++ <area shape="circle" coords="83,334,15" id ="128" alt="stop" onclick="pressMenuRemote('128');">
++ <area shape="circle" coords="107,334,15" id ="385" alt="radio" onclick="pressMenuRemote('385');">
++</map>
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/rc_brown.png b/meta-openvuplus/recipes-vuplus/e2openplugins/files/rc_brown.png
new file mode 100644
index 0000000..bafdc52
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/rc_brown.png
Binary files differ