summaryrefslogtreecommitdiff
path: root/meta-bsp
diff options
context:
space:
mode:
authorhschang <chang@dev3>2021-01-21 06:18:28 (GMT)
committerhschang <chang@dev3>2021-01-21 06:30:04 (GMT)
commit371e097233a1b62a0a09c590237b9d632f718ba1 (patch)
tree1348b7387cb5aab7a571bcc37798424d9b788a63 /meta-bsp
parent0b71da30d78283ba3d4e27432946d137c749fd68 (diff)
Add vuplus-tuner-turbo2 driver.
Diffstat (limited to 'meta-bsp')
-rw-r--r--meta-bsp/conf/machine/include/vuplus-arm32eb.inc2
-rw-r--r--meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2.inc45
-rw-r--r--meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_3.14.28-1.12.bb11
-rw-r--r--meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_3.14.28.bb9
-rw-r--r--meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_4.1.20-1.5.bb11
-rw-r--r--meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_4.1.45-1.17.bb11
6 files changed, 89 insertions, 0 deletions
diff --git a/meta-bsp/conf/machine/include/vuplus-arm32eb.inc b/meta-bsp/conf/machine/include/vuplus-arm32eb.inc
index c7fd299..9429979 100644
--- a/meta-bsp/conf/machine/include/vuplus-arm32eb.inc
+++ b/meta-bsp/conf/machine/include/vuplus-arm32eb.inc
@@ -15,3 +15,5 @@ DEFAULTTUNE = "armv7ahf-neon"
require conf/machine/include/vuplus.inc
require conf/machine/include/arm/arch-armv7a.inc
+
+VUPLUS_FEATURES += "turbo2"
diff --git a/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2.inc b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2.inc
new file mode 100644
index 0000000..f3a99cf
--- /dev/null
+++ b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2.inc
@@ -0,0 +1,45 @@
+DESCRIPTION = "Hardware drivers and blindscan util for Vuplus Tuner Turbo2"
+SECTION = "base"
+LICENSE = "CLOSED"
+require conf/license/license-close.inc
+
+SRCDATE = "20201207"
+FW_SRCDATE = "20201207"
+KV = "${VUPLUS_KERNEL_VERSION}"
+PV = "${KV}"
+PR = "${SRCDATE}"
+
+SRC_URI = " \
+ http://archive.vuplus.com/download/usb/tuner/turbo/vuplus_tuner_turbo2_driver_${PV}_${TARGET_ARCH}_${SRCDATE}.tar.gz;name=driver \
+ http://archive.vuplus.com/download/usb/tuner/turbo/vuplus_tuner_turbo2_bin_fw_${TARGET_ARCH}_${FW_SRCDATE}.tar.gz;name=binfw \
+"
+
+S = "${WORKDIR}"
+
+#inherit module-base
+DEPENDS = "virtual/kernel"
+KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_BUILDDIR}/kernel-abiversion')}"
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/media/usb/vuplus
+ install -m 0644 ${S}/vuplus_tuner_turbo2_driver.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/media/usb/vuplus/vuplus_tuner_turbo2_driver.ko
+ install -d ${D}/lib/firmware/
+ install -m 0644 ${S}/Vuplus_Turbo2_USB_0100.fw ${D}/lib/firmware/Vuplus_Turbo2_USB_0100.fw
+ install -d "${D}/${bindir}"
+ install -m 0755 "${S}/vuplus_turbo2_c" "${D}/${bindir}"
+ install -m 0755 "${S}/vuplus_turbo2_t" "${D}/${bindir}"
+}
+
+pkg_postinst_${PN} () {
+ if [ -d /proc/stb ]; then
+ depmod -a
+ fi
+ true
+}
+
+PACKAGE_ARCH := "${MACHINE_ARCH}"
+FILES_${PN} = "/"
+
+SRC_URI[binfw.md5sum] = "aa1be089011f3bdc15d88d7f70dd4c7e"
+SRC_URI[binfw.sha256sum] = "9a130ee3a67994029eec37366a4cce67031d6d5e8bfda0ed8b6ce59983bbb376"
+
diff --git a/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_3.14.28-1.12.bb b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_3.14.28-1.12.bb
new file mode 100644
index 0000000..0fd4a3e
--- /dev/null
+++ b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_3.14.28-1.12.bb
@@ -0,0 +1,11 @@
+require vuplus-tuner-turbo2.inc
+
+COMPATIBLE_MACHINE = "^(vuultimo4k|vuuno4k)$"
+
+KV = "${VUPLUS_KERNEL_VERSION}-1.12"
+
+SRCDATE_arm = "20201207"
+
+SRC_URI[driver.md5sum] = "a547314d5d9b2b307f8be0587cf01019"
+SRC_URI[driver.sha256sum] = "eb2d5c765b5ae41d929dcd87b28e57b6d4d4559e43dfbefbbdf3d8e7da4c4099"
+
diff --git a/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_3.14.28.bb b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_3.14.28.bb
new file mode 100644
index 0000000..dd218eb
--- /dev/null
+++ b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_3.14.28.bb
@@ -0,0 +1,9 @@
+require vuplus-tuner-turbo2.inc
+
+COMPATIBLE_MACHINE = "^(vusolo4k)$"
+
+SRCDATE_arm = "20201207"
+
+SRC_URI[driver.md5sum] = "6c90c20f8f8bd811ebece927ce7d6698"
+SRC_URI[driver.sha256sum] = "eaf4949e4422339f879ab8093fdc714e61001d423e8016aa67871bcad8eb068f"
+
diff --git a/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_4.1.20-1.5.bb b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_4.1.20-1.5.bb
new file mode 100644
index 0000000..5d3cb6c
--- /dev/null
+++ b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_4.1.20-1.5.bb
@@ -0,0 +1,11 @@
+require vuplus-tuner-turbo2.inc
+
+COMPATIBLE_MACHINE = "^(vuuno4kse|vuzero4k)$"
+
+KV = "${VUPLUS_KERNEL_VERSION}-1.5"
+
+SRCDATE_arm = "20201207"
+
+SRC_URI[driver.md5sum] = "767d0446906251beef3d47441ea6d03f"
+SRC_URI[driver.sha256sum] = "41f276b048380dfbd20834aa3a80a58d82fff8f73d151e88d6396189ff60b967"
+
diff --git a/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_4.1.45-1.17.bb b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_4.1.45-1.17.bb
new file mode 100644
index 0000000..ea7be3f
--- /dev/null
+++ b/meta-bsp/recipes-vuplus/vuplus-tuner-turbo2/vuplus-tuner-turbo2_4.1.45-1.17.bb
@@ -0,0 +1,11 @@
+require vuplus-tuner-turbo2.inc
+
+COMPATIBLE_MACHINE = "^(vuduo4k|vuduo4kse)$"
+
+KV = "${VUPLUS_KERNEL_VERSION}-1.17"
+
+SRCDATE_arm = "20201207"
+
+SRC_URI[driver.md5sum] = "ff1b2fca6f88c8640875a22e1780cae3"
+SRC_URI[driver.sha256sum] = "eee4c5ce7a63bfdc751e07041506021db8617228ce5e58e139bbf784eb53c84e"
+