summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-devtools/mtd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openvuplus/recipes-devtools/mtd')
-rw-r--r--meta-openvuplus/recipes-devtools/mtd/mtd-utils-1.4.9/disable-ubi.patch19
-rw-r--r--meta-openvuplus/recipes-devtools/mtd/mtd-utils-1.4.9/mkfs.ubifs-allow-output-file-creation-on-different-device.patch36
-rw-r--r--meta-openvuplus/recipes-devtools/mtd/mtd-utils_1.4.9.bbappend8
3 files changed, 39 insertions, 24 deletions
diff --git a/meta-openvuplus/recipes-devtools/mtd/mtd-utils-1.4.9/disable-ubi.patch b/meta-openvuplus/recipes-devtools/mtd/mtd-utils-1.4.9/disable-ubi.patch
deleted file mode 100644
index d9384d9..0000000
--- a/meta-openvuplus/recipes-devtools/mtd/mtd-utils-1.4.9/disable-ubi.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- mtd-utils-1.4.9.org/Makefile 2012-04-02 11:41:10.339446661 +0200
-+++ mtd-utils-1.4.9/Makefile 2012-04-02 11:40:33.659447111 +0200
-@@ -30,13 +30,13 @@
- ubidetach ubinize ubiformat ubirename mtdinfo ubirsvol
-
- BINS = $(MTD_BINS)
--BINS += mkfs.ubifs/mkfs.ubifs
--BINS += $(addprefix ubi-utils/,$(UBI_BINS))
-+#BINS += mkfs.ubifs/mkfs.ubifs
-+#BINS += $(addprefix ubi-utils/,$(UBI_BINS))
- SCRIPTS = flash_eraseall
-
- TARGETS = $(BINS)
- TARGETS += lib/libmtd.a
--TARGETS += ubi-utils/libubi.a
-+#TARGETS += ubi-utils/libubi.a
-
- OBJDEPS = $(BUILDDIR)/include/version.h
-
diff --git a/meta-openvuplus/recipes-devtools/mtd/mtd-utils-1.4.9/mkfs.ubifs-allow-output-file-creation-on-different-device.patch b/meta-openvuplus/recipes-devtools/mtd/mtd-utils-1.4.9/mkfs.ubifs-allow-output-file-creation-on-different-device.patch
new file mode 100644
index 0000000..63f7ae2
--- /dev/null
+++ b/meta-openvuplus/recipes-devtools/mtd/mtd-utils-1.4.9/mkfs.ubifs-allow-output-file-creation-on-different-device.patch
@@ -0,0 +1,36 @@
+diff --git a/mkfs.ubifs/mkfs.ubifs.c b/mkfs.ubifs/mkfs.ubifs.c
+index f77e5e6..e002be5 100644
+--- a/mkfs.ubifs/mkfs.ubifs.c
++++ b/mkfs.ubifs/mkfs.ubifs.c
+@@ -324,6 +324,22 @@ static int in_path(const char *dir_name, const char *file_name)
+ return ret;
+ }
+
++/*
++ * same_device - determine if a file is on the same blockdevice as a directory.
++ * @dir_name: directory path name
++ * @file_name: file path name
++ */
++static int same_device(const char *dir_name, const char *file_name)
++{
++ struct stat stat1, stat2;
++
++ if (stat(dir_name, &stat1) == -1)
++ return -1;
++ if (stat(file_name, &stat2) == -1)
++ return -1;
++ return stat1.st_dev == stat2.st_dev;
++}
++
+ /**
+ * calc_min_log_lebs - calculate the minimum number of log LEBs needed.
+ * @max_bud_bytes: journal size (buds only)
+@@ -376,7 +392,7 @@ static int validate_options(void)
+
+ if (!output)
+ return err_msg("no output file or UBI volume specified");
+- if (root && in_path(root, output))
++ if (root && same_device(root, output) && in_path(root, output))
+ return err_msg("output file cannot be in the UBIFS root "
+ "directory");
+ if (!is_power_of_2(c->min_io_size))
diff --git a/meta-openvuplus/recipes-devtools/mtd/mtd-utils_1.4.9.bbappend b/meta-openvuplus/recipes-devtools/mtd/mtd-utils_1.4.9.bbappend
index 6eb3342..6b9198a 100644
--- a/meta-openvuplus/recipes-devtools/mtd/mtd-utils_1.4.9.bbappend
+++ b/meta-openvuplus/recipes-devtools/mtd/mtd-utils_1.4.9.bbappend
@@ -1,7 +1,5 @@
-PR .= "-vuplus0"
+PR .= "-vuplus1"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
-
-DREAMBOX_KERNEL_VERSION = "3.2"
+SRC_URI += "file://mkfs.ubifs-allow-output-file-creation-on-different-device.patch"
-SRC_URI += "${@base_version_less_or_equal('DREAMBOX_KERNEL_VERSION', '2.6.18', 'file://disable-ubi.patch', '', d)}"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"