summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-core/initscripts
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openvuplus/recipes-core/initscripts')
-rwxr-xr-xmeta-openvuplus/recipes-core/initscripts/initscripts-1.0/mountrun.sh3
-rw-r--r--meta-openvuplus/recipes-core/initscripts/initscripts-1.0/volatiles38
-rw-r--r--meta-openvuplus/recipes-core/initscripts/initscripts_1.0.bbappend8
3 files changed, 48 insertions, 1 deletions
diff --git a/meta-openvuplus/recipes-core/initscripts/initscripts-1.0/mountrun.sh b/meta-openvuplus/recipes-core/initscripts/initscripts-1.0/mountrun.sh
new file mode 100755
index 0000000..f5ca2f9
--- /dev/null
+++ b/meta-openvuplus/recipes-core/initscripts/initscripts-1.0/mountrun.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+mountpoint -q /var/volatile || mount /var/volatile
+mkdir -m 0755 -p /var/volatile/run
diff --git a/meta-openvuplus/recipes-core/initscripts/initscripts-1.0/volatiles b/meta-openvuplus/recipes-core/initscripts/initscripts-1.0/volatiles
new file mode 100644
index 0000000..c70d637
--- /dev/null
+++ b/meta-openvuplus/recipes-core/initscripts/initscripts-1.0/volatiles
@@ -0,0 +1,38 @@
+# This configuration file lists filesystem objects that should get verified
+# during startup and be created if missing.
+#
+# Every line must either be a comment starting with #
+# or a definition of format:
+# <type> <owner> <group> <mode> <path> <linksource>
+# where the items are separated by whitespace !
+#
+# <type> : d|f|l : (d)irectory|(f)ile|(l)ink
+#
+# A linking example:
+# l root root 0777 /var/test /tmp/testfile
+# f root root 0644 /var/test none
+#
+# Understanding links:
+# When populate-volatile is to verify/create a directory or file, it will first
+# check it's existence. If a link is found to exist in the place of the target,
+# the path of the target is replaced with the target the link points to.
+# Thus, if a link is in the place to be verified, the object will be created
+# in the place the link points to instead.
+# This explains the order of "link before object" as in the example above, where
+# a link will be created at /var/test pointing to /tmp/testfile and due to this
+# link the file defined as /var/test will actually be created as /tmp/testfile.
+d root root 0755 /var/volatile/cache none
+d root root 1777 /var/volatile/lock none
+d root root 0755 /var/volatile/log none
+d root root 0755 /var/volatile/run none
+d root root 1777 /var/volatile/tmp none
+l root root 0755 /var/cache /var/volatile/cache
+l root root 1777 /var/lock /var/volatile/lock
+l root root 0755 /var/log /var/volatile/log
+l root root 0755 /var/run /var/volatile/run
+l root root 1777 /var/tmp /var/volatile/tmp
+d root root 0755 /var/lock/subsys none
+f root root 0664 /var/log/wtmp none
+f root root 0664 /var/run/utmp none
+
+
diff --git a/meta-openvuplus/recipes-core/initscripts/initscripts_1.0.bbappend b/meta-openvuplus/recipes-core/initscripts/initscripts_1.0.bbappend
index 46b30e6..a9e4420 100644
--- a/meta-openvuplus/recipes-core/initscripts/initscripts_1.0.bbappend
+++ b/meta-openvuplus/recipes-core/initscripts/initscripts_1.0.bbappend
@@ -1,12 +1,15 @@
-PR .= "-vuplus4"
+PR .= "-vuplus5"
BOOTUP = "bootup_3.1"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
+
SRC_URI_append = " \
file://turnoff_power \
file://hotplug_br \
file://make_mac_sector \
file://${BOOTUP} \
+ file://mountrun.sh \
"
do_install_append() {
@@ -19,6 +22,9 @@ do_install_append() {
install -m 0755 ${WORKDIR}/${BOOTUP} ${D}${sysconfdir}/init.d/bootup
ln -sf ../init.d/bootup ${D}${sysconfdir}/rcS.d/S05bootup
+ install -m 0755 ${WORKDIR}/mountrun.sh ${D}${sysconfdir}/init.d
+ ln -s ../init.d/mountrun.sh ${D}${sysconfdir}/rcS.d/S02mountrun.sh
+
# rename umountnfs script because it should run before network is disabled
mv ${D}${sysconfdir}/rc0.d/S31umountnfs.sh ${D}${sysconfdir}/rc0.d/K31umountnfs.sh || /bin/true
mv ${D}${sysconfdir}/rc6.d/S31umountnfs.sh ${D}${sysconfdir}/rc6.d/K31umountnfs.sh || /bin/true