summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-kernel
diff options
context:
space:
mode:
authorChang.H.S <jhs@dev3>2012-11-23 06:13:32 (GMT)
committerChang.H.S <jhs@dev3>2012-11-23 06:13:32 (GMT)
commit9ee8333445ef0abb65e95279e899dc0f98f27bd7 (patch)
tree8a9c45287da992abff41d970d4d6894e47f84c34 /meta-openvuplus/recipes-kernel
init
Diffstat (limited to 'meta-openvuplus/recipes-kernel')
-rw-r--r--meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers.inc66
-rw-r--r--meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers/connector-msg-size-fix.patch29
-rw-r--r--meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers_3.1.1.bb7
3 files changed, 102 insertions, 0 deletions
diff --git a/meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers.inc b/meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers.inc
new file mode 100644
index 0000000..83b4604
--- /dev/null
+++ b/meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers.inc
@@ -0,0 +1,66 @@
+DESCRIPTION = "Sanitized set of kernel headers for the C library's use."
+SECTION = "devel"
+LICENSE = "GPLv2"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
+
+python __anonymous () {
+ major = d.getVar("PV",True).split('.')[0]
+ if major == "3":
+ d.setVar("HEADER_FETCH_VER", "3.0")
+ else:
+ d.setVar("HEADER_FETCH_VER", "2.6")
+}
+
+SRC_URI = "http://archive.vuplus.com/download/kernel/linux-${KV}_${SRCREV}.tar.bz2"
+
+S = "${WORKDIR}/linux-${PV}"
+
+set_arch() {
+ case ${TARGET_ARCH} in
+ alpha*) ARCH=alpha ;;
+ arm*) ARCH=arm ;;
+ cris*) ARCH=cris ;;
+ hppa*) ARCH=parisc ;;
+ i*86*) ARCH=i386 ;;
+ ia64*) ARCH=ia64 ;;
+ mips*) ARCH=mips ;;
+ m68k*) ARCH=m68k ;;
+ powerpc*) ARCH=powerpc ;;
+ s390*) ARCH=s390 ;;
+ sh*) ARCH=sh ;;
+ sparc64*) ARCH=sparc64 ;;
+ sparc*) ARCH=sparc ;;
+ x86_64*) ARCH=x86_64 ;;
+ avr32*) ARCH=avr32 ;;
+ bfin*) ARCH=blackfin ;;
+ microblaze*) ARCH=microblaze ;;
+ esac
+}
+
+do_configure() {
+ set_arch
+ oe_runmake allnoconfig ARCH=$ARCH
+}
+
+do_compile () {
+}
+
+do_install() {
+ set_arch
+ oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+ # Kernel should not be exporting this header
+ rm -f ${D}${exec_prefix}/include/scsi/scsi.h
+
+ # The ..install.cmd conflicts between various configure runs
+ find ${D}${includedir} -name ..install.cmd | xargs rm -f
+}
+
+BBCLASSEXTEND = "nativesdk"
+
+#DEPENDS = "cross-linkage"
+RDEPENDS_${PN}-dev = ""
+RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
+
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS += "unifdef-native"
diff --git a/meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers/connector-msg-size-fix.patch b/meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers/connector-msg-size-fix.patch
new file mode 100644
index 0000000..5d531d6
--- /dev/null
+++ b/meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers/connector-msg-size-fix.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Currently default header is linux-libc-header, which leads the dismatch
+with wrs kernel.
+
+The different headers for same file cause trouble between kerenl module and
+user level binary. E.g. segfault in v86d due to different
+CONNECTOR_MAX_MSG_SIZE in connector.h from the one used by uvesafb.
+
+This fix is work around to sync with wrs kernel headers, and should be removed
+after switching to linux-libc-headers-wrs.
+
+[BUGID #279] fixed by this.
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+Index: linux-2.6.34/include/linux/connector.h
+===================================================================
+--- linux-2.6.34.orig/include/linux/connector.h 2010-09-30 14:15:25.000000000 +0800
++++ linux-2.6.34/include/linux/connector.h 2010-09-30 14:15:43.000000000 +0800
+@@ -48,7 +48,7 @@
+ /*
+ * Maximum connector's message size.
+ */
+-#define CONNECTOR_MAX_MSG_SIZE 16384
++#define CONNECTOR_MAX_MSG_SIZE 65536
+
+ /*
+ * idx and val are unique identifiers which
diff --git a/meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers_3.1.1.bb b/meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers_3.1.1.bb
new file mode 100644
index 0000000..4806ec5
--- /dev/null
+++ b/meta-openvuplus/recipes-kernel/linux-libc-headers/linux-libc-headers_3.1.1.bb
@@ -0,0 +1,7 @@
+require linux-libc-headers.inc
+
+KV = "3.1.1"
+SRCREV = "r2"
+
+SRC_URI[md5sum] = "4dc3ac322453abbfaade7020cddea205"
+SRC_URI[sha256sum] = "1d18eb39677a23eace6b27ee25656c25f21b57be7e77a2adcdd15c76d1c3e875"