[dvbapp] add enable-dependency-tracking to EXTRA_OECONF
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2.bb
index bf991b8..da9a59b 100644 (file)
@@ -108,12 +108,14 @@ SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};t
        file://enigma2_vuplus_mediaplayer_subtitle.patch \
        file://enigma2_vuplus_remove_dreambox_enigma.patch \
        file://enigma2_vuplus_vfd_mode.patch \
-       file://enigma2_vuplus_addlibpythondeps.patch \
        file://enigma2_vuplus_pluginbrowser.patch \
        file://enigma2_vuplus_proc_oom_score_adj.patch \
         file://enigma2_vuplus_fix_standby_name.patch \
         file://enigma2_vuplus_fix_standby_name_skin.patch \
        file://enigma2_vuplus_epng.patch \
+       file://enigma2_vuplus_eptrlist_insert.patch \
+       file://enigma2_vuplus_conversion_error.patch \
+       file://enigma2_vuplus_default_arg_error.patch \
        file://MyriadPro-Regular.otf \
        file://MyriadPro-Semibold.otf \
        file://MyriadPro-SemiboldIt.otf \
@@ -157,7 +159,7 @@ FILES_${PN}-meta = "${datadir}/meta"
 PACKAGES += "${PN}-meta"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-inherit autotools pkgconfig pythonnative
+inherit autotools-brokensep pkgconfig pythonnative
 
 do_configure_prepend() {
        git checkout ${BRANCH}
@@ -182,6 +184,7 @@ do_compile_prepend_vuplus() {
 }
 
 EXTRA_OECONF = " \
+        --enable-dependency-tracking \
        ${@base_contains("VUPLUS_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
        ${@base_contains("VUPLUS_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
        ${@base_contains("VUPLUS_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \