Merge branch 'master' of code.vuplus.com:/opt/repository/openvuplus_3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2.bb
index eee12c7..868ba24 100644 (file)
@@ -26,6 +26,30 @@ DEPENDS = " \
         ntfs-3g \
         dosfstools \
         util-linux \
+        fuse-exfat \
+        satipclient \
+       "
+
+DEPENDS += " \
+       wireless-tools \
+       wpa-supplicant \
+       python-twisted \
+       curlftpfs \
+       fuse \
+       virtual/kernel \
+       aio-grab \
+       librtmp \
+       cdrkit \
+       libcddb \
+       libcdio \
+       avahi \
+       gstreamer1.0-plugins-good \
+       gstreamer1.0-plugins-bad \
+       "
+
+DEPENDS += " \
+       vuplus-3gcommand \
+       vuplus-dlnaserver \
        "
 
 RDEPENDS_${PN} = " \
@@ -35,6 +59,10 @@ RDEPENDS_${PN} = " \
         parted \
        ${PYTHON_RDEPS} \
        ${GST_RDEPENDS} \
+       fuse-exfat \
+       util-linux-partx \
+       vuplus-skins \
+       ${@base_contains("VUPLUS_FEATURES", "dvbproxy", "vuplus-dvb-proxy libgles vuplus-platform-util", "vuplus-dvb-modules", d)} \
        "
 
 PYTHON_RDEPS = " \
@@ -88,6 +116,8 @@ GST_RDEPENDS = "${@base_contains('GST_VERSION', '1.0', ' \
        gstreamer1.0-plugins-ugly-cdio \
        gstreamer1.0-plugins-ugly-dvdsub \
        gstreamer1.0-plugins-ugly-mad \
+       gstreamer1.0-plugins-ugly-amrnb \
+       gstreamer1.0-plugins-ugly-amrwbdec \
        ', ' \
        gst-plugin-dvbmediasink \
        gst-plugin-subsink \
@@ -130,6 +160,8 @@ GST_RDEPENDS = "${@base_contains('GST_VERSION', '1.0', ' \
        gst-plugins-ugly-mad \
        gst-plugins-ugly-mpegstream \
        gst-plugins-ugly-mpegaudioparse \
+       gst-plugins-ugly-amrnb \
+       gst-plugins-ugly-amrwbdec \
        ', d)}"
 
 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
@@ -168,44 +200,51 @@ RDEPENDS_enigma2-plugin-systemplugins-crashreport = "python-twisted-mail python-
 RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostapd bridge-utils"
 
 RDEPENDS_enigma2-plugin-extensions-streamtv = " \
-       librtmp1 \
+       librtmp \
        ${@base_contains("GST_VERSION", "1.0", "gstreamer1.0-plugins-bad-rtmp", "gst-plugins-bad-rtmp", d)} \
 "
 
 DEPENDS += "djmount minidlna"
-RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna "
+RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna vuplus-dlnaserver"
 RDEPENDS_enigma2-plugin-extensions-dlnabrowser = "djmount kernel-module-fuse fuse-utils"
 
-DEPENDS += "opera-hbbtv"
-RDEPENDS_enigma2-plugin-extensions-hbbtv = "opera-hbbtv"
+DEPENDS += "${@base_contains("VUPLUS_FEATURES", "hbbtv", "opera-hbbtv" , "", d)}"
+RDEPENDS_enigma2-plugin-extensions-hbbtv = "${@base_contains("VUPLUS_FEATURES", "hbbtv", "opera-hbbtv" , "", d)}"
+
+DEPENDS += "${@base_contains("VUPLUS_FEATURES", "webkithbbtv", "webkit-hbbtv-browser" , "", d)}"
 
 DEPENDS += "wvdial wvstreams ppp usb-modeswitch usb-modeswitch-data"
 RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usb-modeswitch usb-modeswitch-data wvdial wvstreams \
        kernel-module-ppp-async kernel-module-ppp-deflate kernel-module-ppp-synctty kernel-module-ppp-generic kernel-module-usbserial \
+       vuplus-3gcommand \
 "
 
 RDEPENDS_enigma2-plugin-systemplugins-devicemanager = "util-linux-blkid ntfs-3g dosfstools"
-RDEPENDS_enigma2-plugin-systemplugins-netdrive = "curlftpfs kernel-module-fuse libfuse2"
+RDEPENDS_enigma2-plugin-systemplugins-netdrive = "curlftpfs kernel-module-fuse fuse"
 
 RDEPENDS_enigma2-plugin-systemplugins-backupsuitehdd = "mtd-utils-mkfs.ubifs mtd-utils-nanddump mtd-utils-ubinize"
 RDEPENDS_enigma2-plugin-systemplugins-backupsuiteusb = "enigma2-plugin-extensions-backupsuitehdd"
 
+RDEPENDS_enigma2-plugin-extensions-satipclient = "satipclient"
+
+DEPENDS += "${@base_contains("VUPLUS_FEATURES", "uianimation", "libgles libvugles2" , "", d)}"
+RDEPENDS_${PN}_append_vuplus += "${@base_contains("VUPLUS_FEATURES", "uianimation", "libvugles2" , "", d)}"
+
 PN = "enigma2"
-PR = "r95"
+PR = "r152"
 
 inherit gitpkgv pythonnative
 
 ####################################################
-PV = "experimental-git${SRCPV}"
-PKGV = "experimental-git${GITPKGV}"
-BRANCH = "gst10"
-SRCREV = "${AUTOREV}"
+SRCDATE = "20121128"
+PV = "experimental-git${SRCDATE}"
+BRANCH = "vuplus_experimental"
+SRCREV = ""
 ####################################################
 
 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
 
-#SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH} 
-SRC_URI = "git:///home/joseph/work2/work/enigma2;protocol=file;branch=${BRANCH} \
+SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};rev=${SRCREV} \
        file://enigma2_vuplus_skin.patch \
        file://enigma2_vuplus_mediaplayer.patch \
        file://enigma2_vuplus_remove_dreambox_enigma.patch \
@@ -213,27 +252,20 @@ SRC_URI = "git:///home/joseph/work2/work/enigma2;protocol=file;branch=${BRANCH}
        file://enigma2_vuplus_pluginbrowser.patch \
        file://enigma2_vuplus_proc_oom_score_adj.patch \
         file://enigma2_vuplus_fix_standby_name.patch \
-        file://enigma2_vuplus_fix_standby_name_skin.patch \
-       file://enigma2_vuplus_epng.patch \
-       file://enigma2_vuplus_eptrlist_insert.patch \
-       file://enigma2_vuplus_conversion_error.patch \
-       file://enigma2_vuplus_default_arg_error.patch \
-       file://enigma2_vuplus_wrong_boolean_type.patch \
        file://enigma2_vuplus_disable_subtitle_sync_mode_bug.patch \
-       file://MyriadPro-Regular.otf \
-       file://MyriadPro-Semibold.otf \
-       file://MyriadPro-SemiboldIt.otf \
-       file://750S \
-       file://Vu_HD \
+       file://enigma2_vuplus_networksetup_update_ifaces.patch \
+       file://spinner \
        file://number_key \
 "
 
-SRC_URI_append = " ${@base_contains('GST_VERSION', '1.0', '', 'file://enbalesubtitleshack.patch', d)}"
+SRC_URI_append = " ${@base_contains('GST_VERSION', '1.0', '', 'file://enablesubtitleshack.patch', d)}"
 
 SRC_URI_append = " ${@base_contains("VUPLUS_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch", "", d)}"
 
 LDFLAGS_prepend = "${@base_contains('GST_VERSION', '1.0', ' -lxml2 ', '', d)}"
 
+SRC_URI_append = " file://enigma2_vuplus_inputhotplug.patch"
+
 def change_po():
     import os
     try:
@@ -274,20 +306,7 @@ do_configure_prepend() {
 }
 
 do_compile_prepend_vuplus() {
-       install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
-       install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
-       install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
-       install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
-       install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
-       install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
-       install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
-       install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
-       install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
-       install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
-       install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
-       install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
-       install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
-       install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
+       install -m 0755 ${WORKDIR}/spinner/*.png ${S}/data/skin_default/spinner/
        install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
 }
 
@@ -298,6 +317,7 @@ EXTRA_OECONF = " \
        ${@base_contains("VUPLUS_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
        ${@base_contains("VUPLUS_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
        ${@base_contains("VUPLUS_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
+       ${@base_contains("VUPLUS_FEATURES", "uianimation", "--with-libvugles2" , "", d)} \
        BUILD_SYS=${BUILD_SYS} \
        HOST_SYS=${HOST_SYS} \
        STAGING_INCDIR=${STAGING_INCDIR} \
@@ -312,3 +332,9 @@ python populate_packages_prepend() {
     do_split_packages(d, enigma2_plugindir, '^(\w+/\w+)/(.*/)?\.debug/.*$', 'enigma2-plugin-%s-dbg', '%s (debug)', recursive=True, match_path=True, prepend=True)
 }
 
+INSANE_SKIP_${PN} = "already-stripped"
+INSANE_SKIP_enigma2-plugin-extensions-webbrowser = "build-deps"
+INSANE_SKIP_enigma2-plugin-extensions-modem = "build-deps"
+
+
+