Merge remote-tracking branch 'oe_21/master' into vuplus-3.0-next
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2.bb
index b2f054f..7464f06 100644 (file)
@@ -88,6 +88,8 @@ GST_RDEPENDS = "${@base_contains('GST_VERSION', '1.0', ' \
        gstreamer1.0-plugins-ugly-cdio \
        gstreamer1.0-plugins-ugly-dvdsub \
        gstreamer1.0-plugins-ugly-mad \
+       gstreamer1.0-plugins-ugly-amrnb \
+       gstreamer1.0-plugins-ugly-amrwbdec \
        ', ' \
        gst-plugin-dvbmediasink \
        gst-plugin-subsink \
@@ -130,6 +132,8 @@ GST_RDEPENDS = "${@base_contains('GST_VERSION', '1.0', ' \
        gst-plugins-ugly-mad \
        gst-plugins-ugly-mpegstream \
        gst-plugins-ugly-mpegaudioparse \
+       gst-plugins-ugly-amrnb \
+       gst-plugins-ugly-amrwbdec \
        ', d)}"
 
 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
@@ -190,22 +194,24 @@ RDEPENDS_enigma2-plugin-systemplugins-netdrive = "curlftpfs kernel-module-fuse l
 RDEPENDS_enigma2-plugin-systemplugins-backupsuitehdd = "mtd-utils-mkfs.ubifs mtd-utils-nanddump mtd-utils-ubinize"
 RDEPENDS_enigma2-plugin-systemplugins-backupsuiteusb = "enigma2-plugin-extensions-backupsuitehdd"
 
+DEPENDS += "${@base_contains("VUPLUS_FEATURES", "uianimation", "libgles libvugles2" , "", d)}"
+RDEPENDS_${PN}_append_vuplus += "${@base_contains("VUPLUS_FEATURES", "uianimation", "libgles libvugles2" , "", d)}"
+
 PN = "enigma2"
-PR = "r94"
+PR = "r101"
 
 inherit gitpkgv pythonnative
 
 ####################################################
-PV = "experimental-gitr${SRCPV}"
-PKGV = "experimental-gitr${GITPKGV}"
-BRANCH = "gst10"
+SRCDATE = "20121128"
+PV = "experimental-git${SRCDATE}"
+BRANCH = "vuplus_experimental_gst10"
 SRCREV = ""
 ####################################################
 
 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
 
-#SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} 
-SRC_URI = "git:///home/joseph/work2/work/enigma2;protocol=file;branch=${BRANCH};tag=${SRCREV} \
+SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};rev=${SRCREV} \
        file://enigma2_vuplus_skin.patch \
        file://enigma2_vuplus_mediaplayer.patch \
        file://enigma2_vuplus_remove_dreambox_enigma.patch \
@@ -298,6 +304,7 @@ EXTRA_OECONF = " \
        ${@base_contains("VUPLUS_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
        ${@base_contains("VUPLUS_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
        ${@base_contains("VUPLUS_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
+       ${@base_contains("VUPLUS_FEATURES", "uianimation", "--with-libvugles2" , "", d)} \
        BUILD_SYS=${BUILD_SYS} \
        HOST_SYS=${HOST_SYS} \
        STAGING_INCDIR=${STAGING_INCDIR} \