Support duo4k.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-transtreamproxy.bb
index b6c56a8..6d8764b 100644 (file)
@@ -5,15 +5,23 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
 inherit gitpkgv
 
-PR = "r6"
+PR = "r11"
 
 PV = "0.1+git${SRCPV}"
 PKGV = "0.1+git${GITPKGV}"
 SRCREV_pn-${PN} ?= "${AUTOREV}"
 
-SRC_URI = "git://code.vuplus.com/git/filestreamproxy.git;protocol=git;branch=transtreamproxy"
+DEPENDS += "boost"
+SRC_URI = "\
+       git://code.vuplus.com/git/filestreamproxy.git;protocol=git;branch=transtreamproxy \
+       "
+inherit autotools-brokensep
 
-inherit autotools
+EXTRA_OECONF_vusolo4k += " --enable-ext-pid "
+EXTRA_OECONF_vuultimo4k += " --enable-ext-pid "
+EXTRA_OECONF_vuuno4k += " --enable-ext-pid "
+EXTRA_OECONF_vuuno4kse += " --enable-ext-pid "
+EXTRA_OECONF_vuduo4k += " --enable-ext-pid "
 
 S = "${WORKDIR}/git"
 
@@ -21,3 +29,6 @@ do_install() {
        install -d ${D}/usr/bin
        install -m 0755 ${S}/src/transtreamproxy ${D}/usr/bin/transtreamproxy
 }
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+