Support duo4k.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-transtreamproxy.bb
index af394f3..6d8764b 100644 (file)
@@ -1,28 +1,34 @@
 SUMMARY = "streamproxy manages streaming data to a Mobile device using enigma2"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
-SRCREV = "37a3f198a22d90cdfebf07cf56409cf93a4e74ba"
-PR = "r4"
+PRIORITY = "required"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
-SRC_URI = "file://transtreamproxy.xinetd.in \
-           file://transtreamproxy@.service \
-           file://transtreamproxy.socket \
-           file://transcoding.patch;patch=1;pnum=1 \
-"
+inherit gitpkgv
 
-SCHWERKRAFT_PROJECT = "streamproxy"
+PR = "r11"
 
-inherit autotools schwerkraft-git systemd xinetd
+PV = "0.1+git${SRCPV}"
+PKGV = "0.1+git${GITPKGV}"
+SRCREV_pn-${PN} ?= "${AUTOREV}"
+
+DEPENDS += "boost"
+SRC_URI = "\
+       git://code.vuplus.com/git/filestreamproxy.git;protocol=git;branch=transtreamproxy \
+       "
+inherit autotools-brokensep
+
+EXTRA_OECONF_vusolo4k += " --enable-ext-pid "
+EXTRA_OECONF_vuultimo4k += " --enable-ext-pid "
+EXTRA_OECONF_vuuno4k += " --enable-ext-pid "
+EXTRA_OECONF_vuuno4kse += " --enable-ext-pid "
+EXTRA_OECONF_vuduo4k += " --enable-ext-pid "
+
+S = "${WORKDIR}/git"
 
 do_install() {
-        install -d ${D}/usr/bin
-        install -m 0755 ${S}/src/streamproxy      ${D}/usr/bin/transtreamproxy
-        install -d ${D}${systemd_unitdir}/system
-        ln -sf /dev/null ${D}${systemd_unitdir}/system/transtreamproxy.service
+       install -d ${D}/usr/bin
+       install -m 0755 ${S}/src/transtreamproxy ${D}/usr/bin/transtreamproxy
 }
 
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE_${PN}-systemd = "transtreamproxy.socket"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-XINETD_PACKAGES = "${PN}-xinetd"
-XINETD_SERVICE_${PN}-xinetd = "transtreamproxy"