Merge branch 'master' of code.vuplus.com:/opt/repository/openvuplus_3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / enigma2 / enigma2-transtreamproxy.bb
index cbe06f6..2728e20 100644 (file)
@@ -1,19 +1,31 @@
 SUMMARY = "streamproxy manages streaming data to a Mobile device using enigma2"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
-SRCREV = "37a3f198a22d90cdfebf07cf56409cf93a4e74ba"
-PR = "r5"
+PRIORITY = "required"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
-SRC_URI = " \
-           file://transcoding.patch;patch=1;pnum=1 \
-"
+inherit gitpkgv
 
-SCHWERKRAFT_PROJECT = "streamproxy"
+PR = "r10"
 
-inherit autotools schwerkraft-git
+PV = "0.1+git${SRCPV}"
+PKGV = "0.1+git${GITPKGV}"
+SRCREV_pn-${PN} ?= "${AUTOREV}"
+
+DEPENDS += "boost"
+SRC_URI = "\
+       git://code.vuplus.com/git/filestreamproxy.git;protocol=git;branch=transtreamproxy \
+       file://ext-pid-patch.diff;striplevel=1 \
+       "
+inherit autotools-brokensep
+
+EXTRA_OECONF_vusolo4k += " --enable-ext-pid "
+
+S = "${WORKDIR}/git"
 
 do_install() {
-        install -d ${D}/usr/bin
-        install -m 0755 ${S}/src/streamproxy      ${D}/usr/bin/transtreamproxy
+       install -d ${D}/usr/bin
+       install -m 0755 ${S}/src/transtreamproxy ${D}/usr/bin/transtreamproxy
 }
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+