Merge remote-tracking branch 'oe21/master' into vuplus-3.0
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / e2openplugins / enigma2-plugin-extensions-openwebif.bb
index bdf2242..889c5cb 100644 (file)
@@ -4,16 +4,16 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://README;firstline=10;lastline=12;md5=9c14f792d0aeb54e15490a28c89087f7"
 
 DEPENDS = "python-cheetah-native"
-RDEPENDS_${PN} = "python-cheetah python-json python-unixadmin python-misc python-pyopenssl aio-grab"
+RDEPENDS_${PN} = "python-cheetah python-json python-unixadmin python-misc python-pyopenssl \
+               python-shell aio-grab python-compression python-numbers python-zopeinterface \
+"
 
+SRCREV_pn-${PN}="c30a9aefcf87387e90f0ddbac61ef1aada8cbd6c"
 inherit gitpkgv
-PV = "0.1+git${SRCPV}"
-PKGV = "0.1+git${GITPKGV}"
-PR = "r0.73"
+PV = "1+git${SRCPV}"
+PKGV = "1+git${GITPKGV}"
 
-require openplugins.inc
-
-SRC_URI += "file://openwebif_8001_8002.patch;patch=1;pnum=1"
+require openplugins-distutils.inc
 
 # Just a quick hack to "compile" it
 do_compile() {
@@ -22,10 +22,9 @@ do_compile() {
 }
 
 PLUGINPATH = "/usr/lib/enigma2/python/Plugins/Extensions/${MODULE}"
-do_install() {
+do_install_append() {
        install -d ${D}${PLUGINPATH}
        cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
 }
 
 FILES_${PN} = "${PLUGINPATH}"
-PACKAGES = "${PN}"