[filestreamproxy] some bugs fixed.
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / e2openplugins / enigma2-plugin-extensions-openwebif.bb
index 65817f3..37833fe 100644 (file)
@@ -9,7 +9,7 @@ RDEPENDS_${PN} = "python-cheetah python-json python-unixadmin python-misc python
 inherit gitpkgv
 PV = "0.1+git${SRCPV}"
 PKGV = "0.1+git${GITPKGV}"
-PR = "r0.73"
+PR = "r0.79"
 
 require openplugins.inc
 
@@ -25,5 +25,33 @@ do_install() {
        cp -rp ${S}/plugin/* ${D}${PLUGINPATH}
 }
 
+python do_package_prepend () {
+       boxtypes = [
+               ('bm750', 'duo.jpg', 'vu_normal.png'),
+               ('vuduo2', 'duo2.jpg', 'vu_normal.png'),
+               ('vusolo', 'solo.jpg', 'vu_normal.png'),
+               ('vusolo2', 'solo2.jpg', 'vu_normal.png'),
+               ('vuultimo', 'ultimo.jpg', 'vu_ultimo.png'),
+               ('vuuno', 'uno.jpg', 'vu_normal.png'),
+       ]
+       import os
+       top = '${D}${PLUGINPATH}/public/images/'
+       target_box = 'unknown.jpg'
+       target_remote = 'ow_remote.png'
+       for x in boxtypes:
+               if x[0] == '${MACHINE}':
+                       target_box = x[1]
+                       target_remote = x[2]
+                       break
+       for root, dirs, files in os.walk(top + 'boxes', topdown=False):
+               for name in files:
+                       if target_box != name and name != 'unknown.jpg':
+                               os.remove(os.path.join(root, name))
+       for root, dirs, files in os.walk(top + 'remotes', topdown=False):
+               for name in files:
+                       if target_remote != name and name != 'ow_remote.png':
+                               os.remove(os.path.join(root, name))
+}
+
 FILES_${PN} = "${PLUGINPATH}"
 PACKAGES = "${PN}"